aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pylint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pylint/Makefile')
-rw-r--r--devel/pylint/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/pylint/Makefile b/devel/pylint/Makefile
new file mode 100644
index 000000000000..8ed75b7478d3
--- /dev/null
+++ b/devel/pylint/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pylint
+# Date created: 28 May 2004
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= pylint
+PORTVERSION= 0.4.1
+CATEGORIES= devel python
+MASTER_SITES= ftp://ftp.logilab.org/pub/pylint/
+PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= Analyzes python source code looking for bugs and signs of poor quality
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/logilab/pylint/__init__.py:${PORTSDIR}/devel/py-logilab-common
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>