aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pyrex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pyrex/Makefile')
-rw-r--r--devel/pyrex/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/devel/pyrex/Makefile b/devel/pyrex/Makefile
index 78de3dd246c6..1f0369c4fa30 100644
--- a/devel/pyrex/Makefile
+++ b/devel/pyrex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pyrex
-PORTVERSION= 0.9
+PORTVERSION= 0.9.1
CATEGORIES= devel lang python
MASTER_SITES= http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}
@@ -15,9 +15,6 @@ DISTNAME= Pyrex-${PORTVERSION}
MAINTAINER= perky@FreeBSD.org
COMMENT= Programming Language for writing Python extension modules
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Plex/__init__.py:${PORTSDIR}/devel/py-plex
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Plex/__init__.py:${PORTSDIR}/devel/py-plex
-
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_REINPLACE= yes
@@ -25,8 +22,8 @@ USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^PYINCLUDE =.*|PYINCLUDE=${PYTHON_INCLUDEDIR}|g' \
-e 's|\.\./py|${PREFIX}/bin/py|g' ${WRKSRC}/Demos/Makefile
- @${REINPLACE_CMD} -e "s|'Plex'||g" ${WRKSRC}/setup.py
@${RM} -f ${WRKSRC}/Demos/Makefile.bak
+ @${LN} ${WRKSRC}/pyrexc.py ${WRKSRC}/pyrexc
@${FIND} ${WRKSRC} -name .DS_Store | ${XARGS} ${RM} -f
post-install: