aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qscintilla2-designerplugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qscintilla2-designerplugin/Makefile')
-rw-r--r--devel/qscintilla2-designerplugin/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/qscintilla2-designerplugin/Makefile b/devel/qscintilla2-designerplugin/Makefile
new file mode 100644
index 000000000000..e58d686cb795
--- /dev/null
+++ b/devel/qscintilla2-designerplugin/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: qscintilla2-designerplugin
+# Date created: 2007-02-09
+# Whom: Danny Pansters <danny@ricin.com>
+#
+# $FreeBSD$
+
+PORTNAME= designerplugin
+PORTVERSION= 20070318
+CATEGORIES= devel
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/QScintilla2/ \
+ http://freebsd.ricin.com/ports/distfiles/
+PKGNAMEPREFIX= qscintilla2-
+DISTNAME= QScintilla-1.72-gpl-2-snapshot-${PORTVERSION}
+
+MAINTAINER= danny@ricin.com
+COMMENT= Qt Designer plugin for QScintilla2 (Qt4)
+
+LIB_DEPENDS= qscintilla2.1:${PORTSDIR}/devel/qscintilla2
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc gui xml designer
+HAS_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/designer-Qt4
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} designer.pro )
+
+.include <bsd.port.post.mk>