aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qt4-moc
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt4-moc')
-rw-r--r--devel/qt4-moc/Makefile12
-rw-r--r--devel/qt4-moc/pkg-descr12
-rw-r--r--devel/qt4-moc/pkg-plist4
3 files changed, 6 insertions, 22 deletions
diff --git a/devel/qt4-moc/Makefile b/devel/qt4-moc/Makefile
index 050a5b89baf3..e965164faa35 100644
--- a/devel/qt4-moc/Makefile
+++ b/devel/qt4-moc/Makefile
@@ -3,16 +3,15 @@
PORTNAME= moc
DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= devel
+CATEGORIES= devel
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt meta object compiler
+COMMENT= Qt Meta-Object Compiler
BROKEN_arm= does not compile
USE_QT4= qmake_build
-QT_NONSTANDARD= yes
QT_DIST= yes
HAS_CONFIGURE= yes
@@ -37,14 +36,11 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/tools/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
pre-configure:
- ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/bin|g' \
- -e 's|^TARGET.*|TARGET=moc-qt4|g' \
+ ${REINPLACE_CMD} -e 's|^TARGET.*|TARGET=${MOC:T}|g' \
${BUILD_WRKSRC}/${PORTNAME}.pro
${MKDIR} ${WRKSRC}/mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
pre-build:
cd ${BUILD_WRKSRC}/../bootstrap && ${MAKE}
diff --git a/devel/qt4-moc/pkg-descr b/devel/qt4-moc/pkg-descr
deleted file mode 100644
index 36bc69717e98..000000000000
--- a/devel/qt4-moc/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Qt is a C++ toolkit for application development. It lets application
-developers target all major operating systems with a single application
-source code.
-
-Qt provides a platform-independent API to all central platform functionality:
-GUI, database access, networking, file handling, etc. The Qt library
-encapsulates the different APIs of different operating systems, providing
-the application programmer with a single, common API for all operating systems.
-The native C APIs are encapsulated in a set of well-designed, fully
-object-oriented C++ classes.
-
-WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/devel/qt4-moc/pkg-plist b/devel/qt4-moc/pkg-plist
index 690446be106a..00396d6c04f2 100644
--- a/devel/qt4-moc/pkg-plist
+++ b/devel/qt4-moc/pkg-plist
@@ -1,2 +1,2 @@
-bin/moc-qt4
-%%DEBUG%%bin/moc-qt4.debug
+%%QT_BINDIR%%/moc-qt4
+%%DEBUG%%%%QT_BINDIR%%/moc-qt4.debug