aboutsummaryrefslogtreecommitdiffstats
path: root/devel/rhtvision/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rhtvision/Makefile')
-rw-r--r--devel/rhtvision/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/devel/rhtvision/Makefile b/devel/rhtvision/Makefile
index ea828af8f3de..698c2ae9bcc4 100644
--- a/devel/rhtvision/Makefile
+++ b/devel/rhtvision/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rhtvision
PORTVERSION= 1.1.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tvision
@@ -14,11 +15,21 @@ DISTNAME= rhtvision-${PORTVERSION}.src
MAINTAINER= perky@FreeBSD.org
+BUILD_DEPENDS= ${PERL5}:${PORTSDIR}/lang/perl5
+
WRKSRC= ${WRKDIR}/tvision
USE_GMAKE= yes
-USE_PERL5= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
+PATCHPERL_FILES=config.pl confignt.pl conflib.pl linux/compress \
+ linuxso/makemak.in linuxso/makemak.pl
+
+post-patch:
+.for f in ${PATCHPERL_FILES}
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL5},g' ${WRKSRC}/${f}
+.endfor
+
.include <bsd.port.mk>