aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-byaccr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-byaccr/Makefile')
-rw-r--r--devel/ruby-byaccr/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/ruby-byaccr/Makefile b/devel/ruby-byaccr/Makefile
new file mode 100644
index 000000000000..0321644ebd9f
--- /dev/null
+++ b/devel/ruby-byaccr/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: byaccr
+# Date created: 2 Nov 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= byaccr
+PORTVERSION= 0.0
+CATEGORIES= devel ruby
+MASTER_SITES= http://kt-www.jaist.ac.jp:8000/~ttate/ftp/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+RUBY_NO_RUN_DEPENDS= yes
+
+EXAMPLES= Parser.rb Test.rb cal.y
+
+post-patch:
+ ${PERL} -i.orig -pe 's,^#include <malloc\.h>,#include <stdlib.h>,' ${WRKSRC}/*.[ch]
+
+pre-build:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/byaccr
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_EXAMPLESDIR}/byaccr/
+.endfor
+.endif
+
+.include <bsd.port.mk>