aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-gems/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-gems/Makefile')
-rw-r--r--devel/ruby-gems/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index e116f2b90ec5..0e13af6267eb 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -55,11 +55,13 @@ post-install:
@${TOUCH} ${PREFIX}/${GEMS_DOC_BASE_DIR}/.keep_this
@${LN} -sf ${PREFIX}/bin/gem18 ${PREFIX}/bin/gem
+.if !defined(NOPORTDOCS)
@${FIND} -ds ${PREFIX}/lib/ruby/gems/${RUBY_VER}/doc/${DISTNAME} \
-type f -print | ${SED} -E -e 's,^${PREFIX}/?,,' >> ${TMPPLIST}
@${FIND} -ds ${PREFIX}/lib/ruby/gems/${RUBY_VER}/doc/${DISTNAME} \
-type d -print | ${SED} -E -e 's,^${PREFIX}/?,@dirrm ,' >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/lib/ruby/gems/${RUBY_VER}/doc 2>/dev/null || true" >> ${TMPPLIST}
+.endif
@${ECHO_CMD} "@unexec rmdir %D/lib/ruby/gems/${RUBY_VER} 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/lib/ruby/gems 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/lib/ruby 2>/dev/null || true" >> ${TMPPLIST}