aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-gnomevfs
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-gnomevfs')
-rw-r--r--devel/ruby-gnomevfs/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/ruby-gnomevfs/Makefile b/devel/ruby-gnomevfs/Makefile
index 4159e8b9ee35..2bcfa3cc180d 100644
--- a/devel/ruby-gnomevfs/Makefile
+++ b/devel/ruby-gnomevfs/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
USE_RUBY= yes
USE_GNOME= gnomevfs2
+USE_REINPLACE= yes
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
@@ -30,6 +31,11 @@ INSTALL_TARGET= site-install
DOCS= COPYING.LIB ChangeLog README
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/ruby -w|/bin/env ruby|g' \
+ ${WRKSRC}/tests/*.rb
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${RUBY_MODEXAMPLESDIR}