aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-slang/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-slang/Makefile')
-rw-r--r--devel/ruby-slang/Makefile64
1 files changed, 0 insertions, 64 deletions
diff --git a/devel/ruby-slang/Makefile b/devel/ruby-slang/Makefile
deleted file mode 100644
index d931d431e245..000000000000
--- a/devel/ruby-slang/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
-# $FreeBSD$
-
-PORTNAME= slang
-PORTVERSION= 0.52
-CATEGORIES+= devel ruby
-MASTER_SITES= LOCAL/fenner/ruby-contrib
-DISTNAME= ${PORTNAME}lib-${PORTVERSION:}-1m
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= S-Lang extension module for Ruby
-
-DEPRECATED= Does not work with Ruby 1.9
-EXPIRATION_DATE= 2013-10-10
-
-LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang
-
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}lib
-CONFIGURE_ARGS= --with-slang-include="${LOCALBASE}/include/slang" \
- --with-slang-lib="${LOCALBASE}/lib"
-INSTALL_TARGET= site-install
-
-EXAMPLES_EN= fm.rb smgtest.rb urlview.rb
-EXAMPLES_JA= pager.rb
-DOCS_EN= README changes.txt
-DOCS_JA= README.euc
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-
-.if defined(PKGNAMEPREFIX)
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
-.else
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/ja
-.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
-.endfor
-.for f in ${EXAMPLES_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/ja/
-.endfor
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
-.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
-.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
-.endfor
-.endif
-
-.include <bsd.port.post.mk>