aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-thrift/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-thrift/Makefile')
-rw-r--r--devel/ruby-thrift/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/ruby-thrift/Makefile b/devel/ruby-thrift/Makefile
new file mode 100644
index 000000000000..f8454968e045
--- /dev/null
+++ b/devel/ruby-thrift/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: thrift
+# Date created: 27 September 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thrift
+PORTVERSION= 20070917
+CATEGORIES= devel
+PKGNAMEPREFIX= ruby-
+DISTFILES=
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Ruby interface to thrift
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+post-extract:
+ @${LN} -sfh \
+ `cd ${PORTSDIR}/devel/thrift && ${MAKE} -V WRKSRC`/lib/rb ${WRKSRC}
+
+.include <bsd.port.mk>