aboutsummaryrefslogtreecommitdiffstats
path: root/devel/rubygem-inline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-inline/Makefile')
-rw-r--r--devel/rubygem-inline/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/rubygem-inline/Makefile b/devel/rubygem-inline/Makefile
new file mode 100644
index 000000000000..9970e51cb54e
--- /dev/null
+++ b/devel/rubygem-inline/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ruby-inline
+# Date created: 2003-01-30
+# Whom: Sean Chittenden <seanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= inline
+PORTVERSION= 2.2.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ruby${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= RubyInline-${PORTVERSION}
+DIST_SUBDIR= devel ruby
+
+MAINTAINER= seanc@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= README.txt
+EXAMPLES= example.rb tutorial/example1.rb tutorial/example2.rb
+
+post-install:
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}
+.endfor
+
+.include <bsd.port.mk>