aboutsummaryrefslogtreecommitdiffstats
path: root/devel/sdcc/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/sdcc/files')
-rw-r--r--devel/sdcc/files/patch-aa31
-rw-r--r--devel/sdcc/files/patch-ab102
-rw-r--r--devel/sdcc/files/patch-ac33
-rw-r--r--devel/sdcc/files/patch-ad24
-rw-r--r--devel/sdcc/files/patch-ae36
-rw-r--r--devel/sdcc/files/patch-af38
-rw-r--r--devel/sdcc/files/patch-ag21
7 files changed, 208 insertions, 77 deletions
diff --git a/devel/sdcc/files/patch-aa b/devel/sdcc/files/patch-aa
index a6b3b410cf01..509e0815a760 100644
--- a/devel/sdcc/files/patch-aa
+++ b/devel/sdcc/files/patch-aa
@@ -18,34 +18,3 @@ diff -c -r ../sdcc218Ma.orig/cpp/cpplib.c cpp/cpplib.c
extern char *sys_errlist[];
#endif
#endif
-diff -c -r ../sdcc218Ma.orig/gc/mark.c gc/mark.c
-*** ../sdcc218Ma.orig/gc/mark.c Mon Nov 16 04:59:54 1998
---- gc/mark.c Wed Aug 25 12:44:35 1999
-***************
-*** 653,659 ****
---- 653,663 ----
- # ifdef MSWIN32
- void __cdecl GC_push_one(p)
- # else
-+ # if __FreeBSD__
-+ void _GC_push_one(p)
-+ # else
- void GC_push_one(p)
-+ # endif
- # endif
- word p;
- {
-diff -c -r ../sdcc218Ma.orig/sdcc.src/SDCCicode.c sdcc.src/SDCCicode.c
-diff -c -r ../sdcc218Ma.orig/sdcc.src/SDCCval.c sdcc.src/SDCCval.c
-*** ../sdcc218Ma.orig/sdcc.src/SDCCval.c Thu Jul 1 13:07:16 1999
---- sdcc.src/SDCCval.c Wed Aug 25 18:08:18 1999
-***************
-*** 290,296 ****
-
- /* if hex or octal then set the unsigned flag */
- if ( hex || octal ) {
-- SPEC_USIGN(val->type) = 1 ;
- sscanf(s,scanFmt,&sval);
- } else
- sval = atol(s);
---- 290,295 ----
diff --git a/devel/sdcc/files/patch-ab b/devel/sdcc/files/patch-ab
index ea74f26293f3..f2e8f2b7ec25 100644
--- a/devel/sdcc/files/patch-ab
+++ b/devel/sdcc/files/patch-ab
@@ -1,19 +1,85 @@
-*** configure.orig Thu May 27 14:51:34 1999
---- configure Thu Aug 26 18:15:36 1999
+*** sdcc.src/SDCCval.h.orig Thu Jul 1 09:28:12 1999
+--- sdcc.src/SDCCval.h Mon Nov 29 19:06:01 1999
***************
-*** 1075,1081 ****
- # ./install, which can be erroneously created by make from ./install.sh.
- echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
- echo "configure:1078: checking for a BSD compatible install" >&5
-! if test -z "$INSTALL"; then
- if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
---- 1075,1081 ----
- # ./install, which can be erroneously created by make from ./install.sh.
- echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
- echo "configure:1078: checking for a BSD compatible install" >&5
-! if true; then
- if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
+*** 67,73 ****
+ value *charVal (char * );
+ value *symbolVal (symbol * );
+ void printVal (value * );
+! double floatFromVal (value * );
+ value *array2Ptr (value * );
+ value *valUnaryPM (value * );
+ value *valComplement (value * );
+--- 67,73 ----
+ value *charVal (char * );
+ value *symbolVal (symbol * );
+ void printVal (value * );
+! long floatFromVal (value * );
+ value *array2Ptr (value * );
+ value *valUnaryPM (value * );
+ value *valComplement (value * );
+*** sdcc.src/SDCCval.c.orig Mon Nov 29 19:08:57 1999
+--- sdcc.src/SDCCval.c Mon Nov 29 19:07:48 1999
+***************
+*** 578,584 ****
+ /*------------------------------------------------------------------*/
+ /* floatFromVal - value to unsinged integer conversion */
+ /*------------------------------------------------------------------*/
+! double floatFromVal ( value *val )
+ {
+ if (!val)
+ return 0;
+--- 578,584 ----
+ /*------------------------------------------------------------------*/
+ /* floatFromVal - value to unsinged integer conversion */
+ /*------------------------------------------------------------------*/
+! long floatFromVal ( value *val )
+ {
+ if (!val)
+ return 0;
+***************
+*** 591,612 ****
+ /* if it is not a specifier then we can assume that */
+ /* it will be an unsigned long */
+ if (!IS_SPEC(val->type))
+! return (double) SPEC_CVAL(val->etype).v_ulong;
+
+ if (SPEC_NOUN(val->etype) == V_FLOAT )
+! return (double) SPEC_CVAL(val->etype).v_float ;
+ else {
+ if (SPEC_LONG(val->etype)) {
+ if (SPEC_USIGN(val->etype))
+! return (double) SPEC_CVAL(val->etype).v_ulong ;
+ else
+! return (double) SPEC_CVAL(val->etype).v_long ;
+ }
+ else {
+ if (SPEC_USIGN(val->etype))
+! return (double) SPEC_CVAL(val->etype).v_uint ;
+ else
+! return (double) SPEC_CVAL(val->etype).v_int ;
+ }
+ }
+ }
+--- 591,612 ----
+ /* if it is not a specifier then we can assume that */
+ /* it will be an unsigned long */
+ if (!IS_SPEC(val->type))
+! return (long) SPEC_CVAL(val->etype).v_ulong;
+
+ if (SPEC_NOUN(val->etype) == V_FLOAT )
+! return (long) SPEC_CVAL(val->etype).v_float ;
+ else {
+ if (SPEC_LONG(val->etype)) {
+ if (SPEC_USIGN(val->etype))
+! return (long) SPEC_CVAL(val->etype).v_ulong ;
+ else
+! return (long) SPEC_CVAL(val->etype).v_long ;
+ }
+ else {
+ if (SPEC_USIGN(val->etype))
+! return (long) SPEC_CVAL(val->etype).v_uint ;
+ else
+! return (long) SPEC_CVAL(val->etype).v_int ;
+ }
+ }
+ }
diff --git a/devel/sdcc/files/patch-ac b/devel/sdcc/files/patch-ac
index bcfd3c1d5d2d..23c309d11f16 100644
--- a/devel/sdcc/files/patch-ac
+++ b/devel/sdcc/files/patch-ac
@@ -1,19 +1,16 @@
-*** s51.src/configure.orig Thu Aug 26 18:13:19 1999
---- s51.src/configure Thu Aug 26 18:13:49 1999
+*** s51.src/cmd.src/newcmd.cc.orig Mon Nov 29 19:14:29 1999
+--- s51.src/cmd.src/newcmd.cc Mon Nov 29 19:15:37 1999
***************
-*** 812,818 ****
- # ./install, which can be erroneously created by make from ./install.sh.
- echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
- echo "configure:815: checking for a BSD compatible install" >&5
-! if test -z "$INSTALL"; then
- if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
---- 812,818 ----
- # ./install, which can be erroneously created by make from ./install.sh.
- echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
- echo "configure:815: checking for a BSD compatible install" >&5
-! if true ; then
- if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
+*** 704,710 ****
+--- 704,714 ----
+ cl_listen_console::proc_input(void)
+ {
+ int newsock;
++ #ifdef __FreeBSD__
++ socklen_t size;
++ #else
+ uint size;
++ #endif
+ struct sockaddr_in sock_addr;
+
+ size= sizeof(struct sockaddr);
diff --git a/devel/sdcc/files/patch-ad b/devel/sdcc/files/patch-ad
index 824a1e6ba545..ca6e695d44d0 100644
--- a/devel/sdcc/files/patch-ad
+++ b/devel/sdcc/files/patch-ad
@@ -1,5 +1,5 @@
-*** sdcc51lib/Makefile.in.orig Thu Aug 26 18:55:13 1999
---- sdcc51lib/Makefile.in Thu Aug 26 18:57:01 1999
+*** sdcc51lib/Makefile.in.orig Mon Nov 22 15:49:50 1999
+--- sdcc51lib/Makefile.in Mon Nov 29 19:28:44 1999
***************
*** 63,69 ****
@@ -8,7 +8,7 @@
! mkdir $$model; \
$(MAKE) CFLAGS="$(CFLAGS) --model-$$model" objects; \
mv *.rel $$model; \
- done
+ mv *.asm $$model; \
--- 63,69 ----
models:
@@ -16,9 +16,9 @@
! $(INSTALL) -d -m 755 $$model; \
$(MAKE) CFLAGS="$(CFLAGS) --model-$$model" objects; \
mv *.rel $$model; \
- done
+ mv *.asm $$model; \
***************
-*** 71,80 ****
+*** 73,84 ****
# Compiling and installing everything and runing test
# ---------------------------------------------------
install: installdirs
@@ -26,22 +26,26 @@
for model in $(MODELS); do \
[ -d $$model ] || $(MAKE) all; \
! $(CP) $$model/*.rel *.lib $(datadir)/sdcc51lib/$$model/; \
+! $(CP) $$model/*.asm $(datadir)/sdcc51lib/$$model/; \
+! $(CP) $$model/*.cdb $(datadir)/sdcc51lib/$$model/; \
done
---- 71,80 ----
+--- 73,84 ----
# Compiling and installing everything and runing test
# ---------------------------------------------------
install: installdirs
-! $(INSTALL) -c -m 644 *.c $(datadir)/sdcc51lib/
+! $(INSTALL) *.c $(datadir)/sdcc51lib/
for model in $(MODELS); do \
[ -d $$model ] || $(MAKE) all; \
-! $(INSTALL) -c -m 644 $$model/*.rel *.lib $(datadir)/sdcc51lib/$$model/; \
+! $(INSTALL) $$model/*.rel *.lib $(datadir)/sdcc51lib/$$model/; \
+! $(INSTALL) $$model/*.asm $(datadir)/sdcc51lib/$$model/; \
+! $(INSTALL) $$model/*.cdb $(datadir)/sdcc51lib/$$model/; \
done
***************
-*** 100,109 ****
+*** 104,113 ****
# Creating installation directories
# ---------------------------------
installdirs:
@@ -52,7 +56,7 @@
done
---- 100,109 ----
+--- 104,113 ----
# Creating installation directories
# ---------------------------------
installdirs:
diff --git a/devel/sdcc/files/patch-ae b/devel/sdcc/files/patch-ae
new file mode 100644
index 000000000000..dfc87db13286
--- /dev/null
+++ b/devel/sdcc/files/patch-ae
@@ -0,0 +1,36 @@
+*** sdcc51inc/Makefile.in.orig Mon Oct 18 09:39:07 1999
+--- sdcc51inc/Makefile.in Fri Nov 12 17:21:47 1999
+***************
+*** 37,43 ****
+ # Compiling and installing everything and runing test
+ # ---------------------------------------------------
+ install: all installdirs
+! $(CP) *.h $(datadir)/sdcc51inc/
+
+
+ # Deleting all the installed files
+--- 37,43 ----
+ # Compiling and installing everything and runing test
+ # ---------------------------------------------------
+ install: all installdirs
+! $(INSTALL) -m 644 *.h $(datadir)/sdcc51inc/
+
+
+ # Deleting all the installed files
+***************
+*** 59,65 ****
+ # Creating installation directories
+ # ---------------------------------
+ installdirs:
+! [ -d $(datadir)/sdcc51inc ] || mkdir -p $(datadir)/sdcc51inc
+
+
+ # Creating dependencies
+--- 59,65 ----
+ # Creating installation directories
+ # ---------------------------------
+ installdirs:
+! [ -d $(datadir)/sdcc51inc ] || $(INSTALL) -d -m 755 $(datadir)/sdcc51inc
+
+
+ # Creating dependencies
diff --git a/devel/sdcc/files/patch-af b/devel/sdcc/files/patch-af
new file mode 100644
index 000000000000..bd1aa572a8b5
--- /dev/null
+++ b/devel/sdcc/files/patch-af
@@ -0,0 +1,38 @@
+*** configure.orig Thu May 27 14:51:34 1999
+--- configure Thu Aug 26 18:15:36 1999
+***************
+*** 1075,1081 ****
+ # ./install, which can be erroneously created by make from ./install.sh.
+ echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
+ echo "configure:1078: checking for a BSD compatible install" >&5
+! if test -z "$INSTALL"; then
+ if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+--- 1075,1081 ----
+ # ./install, which can be erroneously created by make from ./install.sh.
+ echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
+ echo "configure:1078: checking for a BSD compatible install" >&5
+! if true; then
+ if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+*** s51.src/configure.orig Thu Aug 26 18:13:19 1999
+--- s51.src/configure Thu Aug 26 18:13:49 1999
+***************
+*** 812,818 ****
+ # ./install, which can be erroneously created by make from ./install.sh.
+ echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
+ echo "configure:815: checking for a BSD compatible install" >&5
+! if test -z "$INSTALL"; then
+ if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+--- 812,818 ----
+ # ./install, which can be erroneously created by make from ./install.sh.
+ echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
+ echo "configure:815: checking for a BSD compatible install" >&5
+! if true ; then
+ if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
diff --git a/devel/sdcc/files/patch-ag b/devel/sdcc/files/patch-ag
new file mode 100644
index 000000000000..152e79fb6148
--- /dev/null
+++ b/devel/sdcc/files/patch-ag
@@ -0,0 +1,21 @@
+*** sdcdb/Makefile.in.orig Mon Nov 29 19:38:51 1999
+--- sdcdb/Makefile.in Mon Nov 29 19:39:26 1999
+***************
+*** 53,60 ****
+ # ---------------------------------------------------
+ install: all installdirs
+ $(INSTALL) -s $(TARGET) $(bindir)/sdcdb
+! cp $(PRJDIR)/sdcdb/sdcdb.el $(bindir)/sdcdb.el
+! cp $(PRJDIR)/sdcdb/sdcdbsrc.el $(bindir)/sdcdbsrc.el
+
+
+ # Deleting all the installed files
+--- 53,60 ----
+ # ---------------------------------------------------
+ install: all installdirs
+ $(INSTALL) -s $(TARGET) $(bindir)/sdcdb
+! $(INSTALL) -c $(PRJDIR)/sdcdb/sdcdb.el $(bindir)/sdcdb.el
+! $(INSTALL) -c $(PRJDIR)/sdcdb/sdcdbsrc.el $(bindir)/sdcdbsrc.el
+
+
+ # Deleting all the installed files