aboutsummaryrefslogtreecommitdiffstats
path: root/devel/simgear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/simgear/Makefile')
-rw-r--r--devel/simgear/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index f1e710ffe67a..a4b5991f6fe0 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -19,9 +19,14 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
jpeg.9:${PORTSDIR}/graphics/jpeg \
alut.1:${PORTSDIR}/audio/freealut \
- osg.48:${PORTSDIR}/graphics/osg \
boost_thread.4:${PORTSDIR}/devel/boost
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
GNU_CONFIGURE= yes