aboutsummaryrefslogtreecommitdiffstats
path: root/devel/slibtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/slibtool/Makefile')
-rw-r--r--devel/slibtool/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/slibtool/Makefile b/devel/slibtool/Makefile
new file mode 100644
index 000000000000..78594b76fc20
--- /dev/null
+++ b/devel/slibtool/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= slibtool
+PORTVERSION= 0.5.5
+CATEGORIES= devel
+MASTER_SITES= http://dl.midipix.org/${PORTNAME}/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Skinny libtool implementation, written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING.SLIBTOOL
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USES= gmake tar:xz
+
+post-patch:
+ ${REINPLACE_CMD} -e "s/make/${MAKE_CMD}/g" ${WRKSRC}/configure
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/slibtool
+
+.include <bsd.port.mk>