aboutsummaryrefslogtreecommitdiffstats
path: root/devel/strace/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/strace/Makefile')
-rw-r--r--devel/strace/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/strace/Makefile b/devel/strace/Makefile
new file mode 100644
index 000000000000..08db6dff258c
--- /dev/null
+++ b/devel/strace/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: strace
+# Date created: Tue May 15 22:29:27 MSD 2001
+# Whom: Alex Semenyaka <alexs@snark.rinet.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= strace
+PORTVERSION= 4.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alexs@snark.rinet.ru
+
+GNU_CONFIGURE= yes
+
+MAN1= strace.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/strace ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/strace-graph ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/strace.1 ${PREFIX}/man/man1
+ -${MKDIR} ${PREFIX}/share/strace
+ ${INSTALL_DATA} ${WRKSRC}/xlate.el ${PREFIX}/share/strace
+
+.include <bsd.port.mk>
letions'>-10/+8 * - Mark BROKEN: does not packagepav2008-08-151-0/+2 * Reset mita@FreeBSD.org due to no commits for 5 months and maintainer-timeouts.linimon2008-08-151-1/+1 * Reset rushani@FreeBSD.org due to maintainer-timeouts and no commits forlinimon2008-08-152-2/+2 * - Update to 0.5.1miwi2008-08-142-4/+4 * Update to 20080804 version.kuriyama2008-08-102-8/+8 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-105-304/+230 * - Update to qt 4.4.1miwi2008-08-053-17/+15 * - s/DOCDIR/DOCSDIR/ and use DATADIR both in Makefile and pkg-plistitetcu2008-07-292-80/+80 * Unbreak on amd64arved2008-07-283-8/+13 * Fix build (add auto-tools)vs2008-07-271-0/+1 * - Remove USE_GCC where it can be satisfied with base compiler on followingpav2008-07-251-1/+0 * - Remove duplicates from MAKE_ENV after inclusion of CC and CXX in default MA...pav2008-07-256-6/+1 * Remove japanese/kterm16c because japanese/kterm now supports thehrs2008-07-2422-677/+74 * - Fix build with NOPORTDOCS=yes.hrs2008-07-232-11/+13 * Fix USE_XORG for the upcoming bsd.port.mk changes (ports/122340).flz2008-07-232-2/+2 * Remove japanese/samba and suggest samba3 instead, after iterwin2008-07-2213-2670/+0 * Update to 8.1.2 Security Update 1. Quoted from the advisory:hrs2008-07-211-3/+3 * - Updates to 2.8.7.dev9.miwi2008-07-195-138/+208 * - Updates to 2.8.6.rel5miwi2008-07-192-6/+7 * Chase net/samba3-3.0.30 upgrade and unbreak.kuriyama2008-07-112-9/+8 * - Bump PORTREVISION after arp updatemiwi2008-07-071-1/+1 * Only run pre-install when NOPORTDOCS isn't setedwin2008-07-051-4/+6 * [Patch] japanese/mh: port to termiosedwin2008-07-054-0/+172 * Update to 20080630.kuriyama2008-07-022-7/+7 * Switch the japanese/sj3 port to termios instead of sgtty.ed2008-07-016-3/+471 * Bump PORTREVISION due to subversion upgrade.lev2008-06-301-1/+1 * (1) Upgrade subversion to version 1.5.0.lev2008-06-301-1/+1 * - respect NOPORTDOCS and NOPORTDATAitetcu2008-06-301-0/+92 * - respect NOPORTDOCS and NOPORTDATAitetcu2008-06-304-121/+28 * Fix installation of documentation (bump PORTREVISION)vs2008-06-252-14/+13 * - Fix build after devel/darts updatemiwi2008-06-232-4/+13 * - Make XLFD of IPA TrueType font more consistent.hrs2008-06-212-21/+21 * - Update to 3.2.5.lippe2008-06-204-20/+19 * Add more MASTER_SITES.hrs2008-06-191-1/+3 * Unbreak (old distfiles not found): update to version 1.3.1.matusita2008-06-192-6/+5 * Standardize placement and style of WWW: lines, and in some casesdougb2008-06-191-1/+2 * - This port has been BROKEN for more than 6 months. It will be removed unlesspav2008-06-191-0/+2 * - Resurrect japanese/lynxpav2008-06-191-0/+1 * - Resurrect, unbreak and update to 2.8.6.rel4pav2008-06-195-0/+226 * - Delete expired port japanese/vje30: depends on forbidden port misc/compat3xpav2008-06-199-465/+0 * - Delete expired japanese/lynx port: Leaves behind config file on deinstallpav2008-06-198-241/+0 * - Reset maintainer address:pav2008-06-194-4/+4 * Update to 0.08000okazaki2008-06-143-4/+11 * Update to 0.02.okazaki2008-06-123-5/+5 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-0676-55/+76 * Fix DEPENDS and bump PORTREVISIONitetcu2008-06-061-2/+3 * - Remove obsolete fp=[y|n] modifier in fonts.dir.hrs2008-05-314-10/+14 * Remove japanese/motoya-ttfonts. The EULA is too restrictive forhrs2008-05-319-421/+0 * Remove obsolete fp=[y|n] modifier in fonts.dir.hrs2008-05-3112-28/+30 * - Remove obsolete fp=[y|n] modifier in fonts.dir.hrs2008-05-316-15/+30 * - Sync with lastes p5-Mail-SpamAssassinmiwi2008-05-303-6/+24 * Update to 20080430 version.kuriyama2008-05-272-7/+7 * [MAINTAINER] japanese/latex-japanese: change portname to platex-japaneseedwin2008-05-266-89/+5 * Remove japanese/kochi-cidfonts. This CID-keyed font is suspectedhrs2008-05-255-51/+0 * Add Ume Font, another free Japanese TrueType font based onhrs2008-05-2515-0/+551 * Remove unused variables.hrs2008-05-252-18/+4 * - Add install script for adding XLFD.hrs2008-05-2512-112/+340 * Remove unused variables from $PLIST_SUB.hrs2008-05-253-9/+3 * Remove japanese/truetypefonts. This TrueType font is suspectedhrs2008-05-259-162/+0 * - Include some ports in perl5 category.araujo2008-05-191-1/+1 * Update to 0.2.0.nobutaka2008-05-197-96/+19 * Fix build with the latest uim.nobutaka2008-05-181-3/+11 * Remove ${DATADIR} properly.hrs2008-05-174-0/+4 * - Update to 20080429miwi2008-05-164-8/+8 * Add port japanese/p5-Lingua-JA-Kana:sat2008-05-165-0/+42 * Remove japanese/epson-ttfonts. The EULA is too restrictive forhrs2008-05-1310-199/+0 * - Improve fontconfig support.hrs2008-05-1318-424/+302 * - Add fontconfig support.hrs2008-05-1318-546/+378 * Use conf.avail/ directory and install symlinks into conf.d/ directory.hrs2008-05-126-12/+36 * Chase shlib version bump of uim.ume2008-05-121-2/+2 * Update to 1.5.0.nobutaka2008-05-113-5/+5 * Make migemo ports to properly handle a case that EMACS_PORT_NAME is defined i...nobutaka2008-05-064-4/+7 * Fix build error.nobutaka2008-05-061-1/+1 * 3dinoex2008-04-301-1/+1 * Reset aaron's port maintainerships due to many maintainer-timeouts.linimon2008-04-291-1/+1 * Fix autoconf build issue.lx2008-04-281-0/+11 * - Fix DESKTOP_ENTRIESmiwi2008-04-281-2/+2 * - Update to 3.2.1miwi2008-04-273-28/+66 * Fix BROKEN on gcc 4.2.motoyuki2008-04-262-11/+7 * - Update to version 20080420lwhsu2008-04-264-8/+8 * - Fix buildmiwi2008-04-241-2/+4 * - Fix build after xorg cleanupmiwi2008-04-231-1/+2 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-20122-296/+271 * - Take advantage of CPAN macro from bsd.sites.mk, change ${MASTER_SITE_PERL_C...araujo2008-04-1713-26/+13 * Update to 8.1.2. Bug fixes and enhancements can be found athrs2008-04-141-3/+3 * - Sync with the latest mail/p5-Mail-SpamAssassin.clsung2008-04-132-4/+4 * Change maintainers e-mail address.ehaupt2008-04-111-2/+2 * - Move from versioned tcl/tk CATEGORIES to simple tcl and tk categoriespav2008-04-098-8/+8 * - Update to 0.97clsung2008-04-072-4/+4 * - Add ruby 1.9 supportstas2008-04-061-3/+2 * - Update to 0.97clsung2008-04-012-4/+4 * - Update to 0.97miwi2008-03-312-4/+8 * - Update to 0.9.11p1miwi2008-03-306-50/+46 * - Update to 20080327miwi2008-03-304-28/+38 * - Unbreak with gcc42pav2008-03-282-7/+24 * There are problems about japanese/samba and it should beerwin2008-03-271-0/+7 * - Chase shlib version of net-mgmt/net-snmp.kuriyama2008-03-273-0/+3 * - Update to 0.97clsung2008-03-272-7/+8 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-263-3/+0 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-254-8/+5 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-252-4/+3 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-241-2/+2 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-244-8/+8 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-244-8/+4 * Fix build error with gcc-4.2.nobutaka2008-03-244-4/+55 * Chase shared library version bump of databases/namazu2.nobutaka2008-03-231-1/+1 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-232-5/+3 * - Remove USE_GETOPT_LONG which is a no-op since March 2007pav2008-03-203-3/+0 * - Drop maintainership of this maintainer.lippe2008-03-192-2/+2 * The original babel package for LaTeX does not have an option Japanese.miwi2008-03-159-0/+171 * - Update master sitesmiwi2008-03-157-17/+34 * - Update to 0.20007miwi2008-03-153-7/+23 * Update to Qt 4.3.4lofi2008-03-142-5/+3 * - Replace USE_XPM with a list of required xorg componentspav2008-03-112-4/+4 * Unbreak japanese/samba by fixing pkg-plistmita2008-03-091-1/+0 * - Update to 2.7.0-20070801miwi2008-03-073-19/+18 * - Remove unneeded quotes in COMMENTSmiwi2008-03-071-1/+1 * - Update to 0.20004miwi2008-03-073-15/+12 * Update to 20080229.kuriyama2008-03-042-7/+7 * Update $MASTER_SITES.hrs2008-03-031-2/+2 * Update to 13.1yoichi2008-03-03