aboutsummaryrefslogtreecommitdiffstats
path: root/devel/subversion17/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'devel/subversion17/Makefile.common')
-rw-r--r--devel/subversion17/Makefile.common10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/subversion17/Makefile.common b/devel/subversion17/Makefile.common
index 0a1442238267..aa557b758034 100644
--- a/devel/subversion17/Makefile.common
+++ b/devel/subversion17/Makefile.common
@@ -3,7 +3,7 @@
PORTNAME= subversion
PORTVERSION= 1.7.14
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
DIST_SUBDIR= subversion17
@@ -47,7 +47,7 @@ GNOME_KEYRING_LIB_DEPENDS= libgcr.so:${PORTSDIR}/security/gnome-keyring
KDE_KWALLET_CONFIGURE_OFF= --without-kwallet
KDE_KWALLET_CONFIGURE_ON= --with-kwallet=${KDE4_PREFIX}
-KDE_KWALLET_USE= KDE4=kdelibs runtime
+KDE_KWALLET_USE= KDE4=kdelibs,runtime
MAINTAINER_DEBUG_CFLAGS= -g
MAINTAINER_DEBUG_CONFIGURE_ON= --enable-maintainer-mode --enable-debug
@@ -123,3 +123,9 @@ post-patch:
.if ${PORT_OPTIONS:MFREEBSD_TEMPLATE} && defined(ORGANIZATION)
@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
.endif
+# shebangfix
+ ${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
+ | ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+ -e '1s|#\!/bin/env|#\!/usr/bin/env|' \
+ -e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
+