aboutsummaryrefslogtreecommitdiffstats
path: root/devel/subversion
diff options
context:
space:
mode:
Diffstat (limited to 'devel/subversion')
-rw-r--r--devel/subversion/Makefile44
-rw-r--r--devel/subversion/pkg-comment1
-rw-r--r--devel/subversion/pkg-descr4
-rw-r--r--devel/subversion/pkg-plist1
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
new file mode 100644
index 000000000000..e6c5ceb510ed
--- /dev/null
+++ b/devel/subversion/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: subversion
+# Date created: 10 September 2001
+# Whom: rooneg@electricjellyfish.net
+#
+# $FreeBSD$
+
+PORTNAME= subversion
+PORTVERSION= r727
+CATEGORIES= devel
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= rooneg@electricjellyfish.net
+
+NO_BUILD= nothing to build
+NO_INSTALL= nothing to install
+NO_CDROM= nothing to ship
+NO_PACKAGE= nothing to package here yet
+
+RESTRICTED= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${ECHO} "*************************************************************"
+ @${ECHO}
+ @${ECHO} "The current release of the FreeBSD port of Subversion is"
+ @${ECHO} "available from http://electricjellyfish.net/subversion.tar.gz"
+ @${ECHO} "and from the main Subversion svn repository at"
+ @${ECHO} "http://svn.collab.net/repos/svn. By request of its"
+ @${ECHO} "developers it is not being distributed with the ports tree"
+ @${ECHO} "until the project makes its first beta release."
+ @${ECHO}
+ @${ECHO} "THERE IS NOTHING TO BUILD HERE. USE THIS:"
+ @${ECHO}
+ @${ECHO} " http://electricjellyfish.net/subversion.tar.gz"
+ @${ECHO}
+ @${ECHO} "Check out Subversion's website too:"
+ @${ECHO}
+ @${ECHO} " http://subversion.tigris.org/"
+ @${ECHO}
+ @${ECHO} "*************************************************************"
+
+.include <bsd.port.mk>
diff --git a/devel/subversion/pkg-comment b/devel/subversion/pkg-comment
new file mode 100644
index 000000000000..3d5a71dce562
--- /dev/null
+++ b/devel/subversion/pkg-comment
@@ -0,0 +1 @@
+Version control system
diff --git a/devel/subversion/pkg-descr b/devel/subversion/pkg-descr
new file mode 100644
index 000000000000..b0743f27a8c3
--- /dev/null
+++ b/devel/subversion/pkg-descr
@@ -0,0 +1,4 @@
+Subversion is a version control system designed to be as similar to cvs(1)
+as possible, while fixing many outstanding problems with cvs(1).
+
+WWW: http://subversion.tigris.org/
diff --git a/devel/subversion/pkg-plist b/devel/subversion/pkg-plist
new file mode 100644
index 000000000000..ceac9fcb18bd
--- /dev/null
+++ b/devel/subversion/pkg-plist
@@ -0,0 +1 @@
+@comment "this port is a placeholder, and installs no files."