aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/git/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 014b6e3fadba..fd12d349d365 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -185,6 +185,7 @@ WANT_PERL= yes
OPTIONS= GUI "Enable building of GUI tools" off \
SVN "Enable required dependencies for SVN tools" off \
+ SVN_FBSD "Use subversion-freebsd dependency (implies SVN)" off \
GITWEB "Install gitweb" off \
CONTRIB "Install contributed scripts" on \
P4 "Enable Perforce support" on \
@@ -265,10 +266,14 @@ PLIST_SUB+= GUI="@comment "
MAKE_ARGS+= NO_TCLTK=yes
.endif
-.ifdef (WITH_SVN)
+.ifdef (WITH_SVN) || defined(WITH_SVN_FBSD)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
- svn:${PORTSDIR}/devel/subversion
+ ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion
+.ifdef (WITH_SVN_FBSD)
+RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion-freebsd
+.else
+RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+.endif
PLIST_SUB+= SVN=""
MAN1+= git-svn.1
.else