aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ocaml-camomile/Makefile2
-rw-r--r--devel/ocaml-pcre/Makefile2
-rw-r--r--devel/ocaml-sdl/Makefile2
-rw-r--r--devel/ocaml-ulex/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 7d93811352d2..0f87e5248f84 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -19,6 +19,8 @@ COMMENT= A comprehensive Unicode library for objective caml language
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+BROKEN= Changes permissions of installed file
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/devel/ocaml-pcre/Makefile b/devel/ocaml-pcre/Makefile
index 0fc9269a6930..a4106383d47f 100644
--- a/devel/ocaml-pcre/Makefile
+++ b/devel/ocaml-pcre/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre-utf8
+BROKEN= Changes permissions of installed file
+
USE_GMAKE= yes
MAKE_ENV= OCAML_LIB_INSTALL="${PREFIX}/lib/ocaml/site-lib/pcre" \
INCDIRS="${LOCALBASE}/include" LIBDIRS="${LOCALBASE}/lib"
diff --git a/devel/ocaml-sdl/Makefile b/devel/ocaml-sdl/Makefile
index de983b2403cd..ff5d28fdd2de 100644
--- a/devel/ocaml-sdl/Makefile
+++ b/devel/ocaml-sdl/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
lablgl:${PORTSDIR}/graphics/ocaml-lablgl
+BROKEN= Changes permissions of installed file
+
USE_SDL= sdl ttf image mixer
USE_AUTOCONF_VER=259
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/ocaml-ulex/Makefile b/devel/ocaml-ulex/Makefile
index 079c9a41a4d7..732bbee92f83 100644
--- a/devel/ocaml-ulex/Makefile
+++ b/devel/ocaml-ulex/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+BROKEN= Changes permissions of installed file
+
USE_GMAKE= yes
ALL_TARGET= all all.opt