aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-reshape/Makefile24
-rw-r--r--devel/R-cran-reshape/distinfo2
-rw-r--r--devel/R-cran-reshape/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index db3de296b6c5..121055155b26 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -12,6 +12,7 @@
SUBDIR += R-cran-iterators
SUBDIR += R-cran-itertools
SUBDIR += R-cran-plyr
+ SUBDIR += R-cran-reshape
SUBDIR += SpecTcl
SUBDIR += ZendOptimizer
SUBDIR += aap
diff --git a/devel/R-cran-reshape/Makefile b/devel/R-cran-reshape/Makefile
new file mode 100644
index 000000000000..148374974ef3
--- /dev/null
+++ b/devel/R-cran-reshape/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: R-cran-reshape
+# Date created: 2011-08-30
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reshape
+PORTVERSION= 0.8.4
+CATEGORIES= devel
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= An R package for flexibly restructuring and aggregating data
+
+LICENSE= MIT
+
+RUN_DEPENDS= R-cran-plyr>0:${PORTSDIR}/devel/R-cran-plyr
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-reshape/distinfo b/devel/R-cran-reshape/distinfo
new file mode 100644
index 000000000000..666fc2505af0
--- /dev/null
+++ b/devel/R-cran-reshape/distinfo
@@ -0,0 +1,2 @@
+SHA256 (reshape_0.8.4.tar.gz) = a112bdb3a8bfd27b1ed1fbf1119b0c9318205073d0fae4a25d5b97b973a0ae20
+SIZE (reshape_0.8.4.tar.gz) = 38923
diff --git a/devel/R-cran-reshape/pkg-descr b/devel/R-cran-reshape/pkg-descr
new file mode 100644
index 000000000000..a6394c5bd877
--- /dev/null
+++ b/devel/R-cran-reshape/pkg-descr
@@ -0,0 +1,6 @@
+Reshape (hopefully) makes it easy to do what you have been struggling
+to do with tapply, by, aggregate, xtabs, apply and summarise. It
+is also useful for getting your data into the correct structure for
+lattice or ggplot plots.
+
+WWW: http://had.co.nz/reshape/