aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/py-pyicu/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/devel/py-pyicu/Makefile b/devel/py-pyicu/Makefile
index 6db074739352..460c6226b8c4 100644
--- a/devel/py-pyicu/Makefile
+++ b/devel/py-pyicu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pyicu
PORTVERSION= 1.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,14 +15,17 @@ COMMENT= Python extension wrapping IBM's ICU C++ API #'
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libicudata.so:devel/icu
+
USES?= python
+USES+= compiler:c++11-lib
+USE_CXXSTD= gnu++11
USE_PYTHON= distutils autoplist
-MAKE_ENV+= PYICU_INCLUDES="${PREFIX}/include" \
- PYICU_CFLAGS="-w:-DPYICU_VER=\"${PORTVERSION}\"" \
- PYICU_LFLAGS="-L${PREFIX}/lib"
-
-LIB_DEPENDS+= libicudata.so:devel/icu
+MAKE_ENV+= PYICU_INCLUDES="${LOCALBASE}/include" \
+ PYICU_CFLAGS="${CXXFLAGS:ts:}" \
+ PYICU_LFLAGS="-L${LOCALBASE}/lib"
+CFLAGS+= -w -DPYICU_VER=\"${PORTVERSION}\"
pre-configure:
@if [ ! -e ${LOCALBASE}/lib/libicule.so ]; then \