aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/hhdate/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/devel/hhdate/Makefile b/devel/hhdate/Makefile
index 010541a5daed..ee1812188a28 100644
--- a/devel/hhdate/Makefile
+++ b/devel/hhdate/Makefile
@@ -1,28 +1,28 @@
# Created by: Andreas Sommer <andreas.sommer87@googlemail.com>
# $FreeBSD$
-PORTNAME= hhdate
+PORTNAME= hhdate
# New versions aren't released often, so using the number of commits since
# last release as a.b.c.NUMCOMMITS (see `git describe --tags ${GH_TAGNAME}`).
# 35 = commit a little after 2.1.0 to have LICENSE file and fixed unit tests.
-PORTVERSION= 2.1.0.35
-CATEGORIES= devel
+PORTVERSION= 2.1.0.35
+CATEGORIES= devel
-MAINTAINER= andreas.sommer87@googlemail.com
-COMMENT= Date and time library based on the C++11 (and beyond) <chrono> header
+MAINTAINER= andreas.sommer87@googlemail.com
+COMMENT= Date and time library based on the C++11 (and beyond) <chrono> header
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USE_GITHUB= yes
-GH_ACCOUNT= HowardHinnant
-GH_PROJECT= date
-GH_TAGNAME= 3ab6510cab764c1a20926b1e8442af4c9e8a16b2
+USE_GITHUB= yes
+GH_ACCOUNT= HowardHinnant
+GH_PROJECT= date
+GH_TAGNAME= 3ab6510cab764c1a20926b1e8442af4c9e8a16b2
-NO_ARCH= yes
-NO_BUILD= yes
+NO_ARCH= yes
+NO_BUILD= yes
-PLIST_FILES= include/hhdate/date.h
+PLIST_FILES= include/hhdate/date.h
# TODO add timezone support when interest grows
OPTIONS_DEFINE= TEST
@@ -34,11 +34,9 @@ USE_CXXSTD= c++11
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MTEST}
-post-extract:
+post-extract-TEST-on:
${INSTALL_DATA} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
${INSTALL_DATA} ${FILESDIR}/test-minimal.cpp ${WRKSRC}/test/test-minimal.cpp
-.endif
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/hhdate