aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/wftk/Makefile60
-rw-r--r--devel/wftk/distinfo3
-rw-r--r--devel/wftk/files/patch-wftk::poll.h11
-rw-r--r--devel/wftk/files/patch-wftk::region.h11
-rw-r--r--devel/wftk/files/patch-wftk::timer.h11
-rw-r--r--devel/wftk/pkg-descr8
-rw-r--r--devel/wftk/pkg-plist67
8 files changed, 0 insertions, 172 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 260e9b0cedd0..9e223749e18d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1702,7 +1702,6 @@
SUBDIR += vstr
SUBDIR += vtcl
SUBDIR += websvn
- SUBDIR += wftk
SUBDIR += wfut
SUBDIR += wininfo
SUBDIR += wxGlade
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
deleted file mode 100644
index 78822689d72d..000000000000
--- a/devel/wftk/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# New ports collection makefile for: libuta
-# Date created: 29 March 2001
-# Whom: Oliver Lehmann <lehmann@ans-netz.de>
-#
-# $FreeBSD$
-#
-
-PORTNAME= wftk
-PORTVERSION= 0.7.1
-PORTREVISION= 1
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.worldforge.org/pub/worldforge/libs/wftk/
-
-MAINTAINER= oliver@FreeBSD.org
-COMMENT= A Graphical User Interface library for C++
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
-
-OPTIONS= SDL_MIXER "music and sound support" off
-
-USE_FREETYPE= yes
-USE_SDL= sdl
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack
-USE_GCC= 3.4+
-
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
-CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE}
-
-WANT_SDL= yes
-
-SDL11_FILES= configure wftk/sge_blib.h wftk/sge_blib.cpp wftk/sge_draw.h \
- wftk/sge_draw.cpp wftk/rotozoom.h wftk/surface.cpp \
- wftk/surface_io.cpp wftk/screensurface.cpp wftk/timer.cpp \
- wftk/poll.cpp wftk/sdlhandler.cpp wftk/rootwindow.cpp \
- wftk/mouse.cpp wftk/joystick.cpp wftk/mixer.cpp wftk/color.h \
- wftk/rect.h wftk/region.h wftk/keysym.h wftk/pixelformat.h \
- wftk/surface.h wftk/refobj.h wftk/focus.h wftk/application.h \
- wftk/mouse.h wftk/joystick.h wftk/sound.h wftk/mixer.h \
- wftk/mutex.h wftk/timer.h wftk/poll.h wftk/sdlhandler.h
-
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_SDL:Mmixer}!=""
-WITH_SDL_MIXER= yes
-.endif
-
-.if defined(WITH_SDL_MIXER)
-USE_SDL+= mixer
-.endif
-
-post-patch:
-.for i in ${SDL11_FILES}
- @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/devel/wftk/distinfo b/devel/wftk/distinfo
deleted file mode 100644
index 516ef9acf3ae..000000000000
--- a/devel/wftk/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (wftk-0.7.1.tar.gz) = be936bef97a17a47292f0cfac5b7793a
-SHA256 (wftk-0.7.1.tar.gz) = 80b860aa7fc63bd31fd1deb721070d57f69c9aaf3e7509c9a46d66d63e72ec05
-SIZE (wftk-0.7.1.tar.gz) = 877100
diff --git a/devel/wftk/files/patch-wftk::poll.h b/devel/wftk/files/patch-wftk::poll.h
deleted file mode 100644
index d161072a4683..000000000000
--- a/devel/wftk/files/patch-wftk::poll.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- wftk/poll.h.orig Sun May 8 00:11:35 2005
-+++ wftk/poll.h Sun May 8 00:11:51 2005
-@@ -115,7 +115,7 @@
- virtual void event(int mask) = 0;
-
- typedef Application::FloatingEvent<Poll> BaseEvent;
-- friend class BaseEvent;
-+ friend class Application::FloatingEvent<Poll>;
- class Event : public BaseEvent
- {
- public:
diff --git a/devel/wftk/files/patch-wftk::region.h b/devel/wftk/files/patch-wftk::region.h
deleted file mode 100644
index c1b6f280bdc6..000000000000
--- a/devel/wftk/files/patch-wftk::region.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- wftk/region.h.orig Sat May 7 23:58:28 2005
-+++ wftk/region.h Sun May 8 00:01:36 2005
-@@ -166,7 +166,7 @@
- // const_iterator has to be declared after RegionBox
-
- /// Iterator over points in the region
-- friend class const_iterator
-+ class const_iterator
- {
- public:
- const_iterator() : box_(0) {}
diff --git a/devel/wftk/files/patch-wftk::timer.h b/devel/wftk/files/patch-wftk::timer.h
deleted file mode 100644
index 7fc5b055ba8d..000000000000
--- a/devel/wftk/files/patch-wftk::timer.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- wftk/timer.h.orig Sat May 7 23:58:33 2005
-+++ wftk/timer.h Sun May 8 00:03:52 2005
-@@ -184,7 +184,7 @@
- static std::set<Timer*> runningTimers_;
-
- typedef Application::FloatingEvent<Timer> BaseEvent;
-- friend class BaseEvent;
-+ friend class Application::FloatingEvent<Timer>;
- class Event : public BaseEvent
- {
- public:
diff --git a/devel/wftk/pkg-descr b/devel/wftk/pkg-descr
deleted file mode 100644
index 03621ec47631..000000000000
--- a/devel/wftk/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-wftk is a Graphical User Interface library for C++ that uses SDL
-as its output layer. It allows application and game programmers to
-put together portable graphical applications easily. wftk has a
-range of already implemented widgets and uses libsigc++ as a signal
-dispatching system. It also performs resource management and has a
-sound system.
-
-WWW: http://www.worldforge.org/dev/eng/libraries/wftk
diff --git a/devel/wftk/pkg-plist b/devel/wftk/pkg-plist
deleted file mode 100644
index 5729f7096644..000000000000
--- a/devel/wftk/pkg-plist
+++ /dev/null
@@ -1,67 +0,0 @@
-include/wftk-0.7/wftk/debug.h
-include/wftk-0.7/wftk/debug_timer.h
-include/wftk-0.7/wftk/color.h
-include/wftk-0.7/wftk/point.h
-include/wftk-0.7/wftk/rect.h
-include/wftk-0.7/wftk/region.h
-include/wftk-0.7/wftk/keysym.h
-include/wftk-0.7/wftk/pixelformat.h
-include/wftk-0.7/wftk/painter.h
-include/wftk-0.7/wftk/surface.h
-include/wftk-0.7/wftk/screensurface.h
-include/wftk-0.7/wftk/font.h
-include/wftk-0.7/wftk/ref_map.h
-include/wftk-0.7/wftk/refobj.h
-include/wftk-0.7/wftk/focus.h
-include/wftk-0.7/wftk/screenarea.h
-include/wftk-0.7/wftk/widget.h
-include/wftk-0.7/wftk/singlecontainer.h
-include/wftk-0.7/wftk/cornercontainer.h
-include/wftk-0.7/wftk/box.h
-include/wftk-0.7/wftk/table.h
-include/wftk-0.7/wftk/filler.h
-include/wftk-0.7/wftk/movie.h
-include/wftk-0.7/wftk/rootwindow.h
-include/wftk-0.7/wftk/application.h
-include/wftk-0.7/wftk/resources.h
-include/wftk-0.7/wftk/dialog.h
-include/wftk-0.7/wftk/bordereddialog.h
-include/wftk-0.7/wftk/mouse.h
-include/wftk-0.7/wftk/pointer.h
-include/wftk-0.7/wftk/joystick.h
-include/wftk-0.7/wftk/label.h
-include/wftk-0.7/wftk/button.h
-include/wftk-0.7/wftk/pushbutton.h
-include/wftk-0.7/wftk/togglebutton.h
-include/wftk-0.7/wftk/lineedit.h
-include/wftk-0.7/wftk/multilineedit.h
-include/wftk-0.7/wftk/slider.h
-include/wftk-0.7/wftk/listbox.h
-include/wftk-0.7/wftk/sound.h
-include/wftk-0.7/wftk/sample.h
-include/wftk-0.7/wftk/music.h
-include/wftk-0.7/wftk/mixer.h
-include/wftk-0.7/wftk/video.h
-include/wftk-0.7/wftk/videowidget.h
-include/wftk-0.7/wftk/progressdialog.h
-include/wftk-0.7/wftk/terminal.h
-include/wftk-0.7/wftk/mutex.h
-include/wftk-0.7/wftk/wftk.h
-include/wftk-0.7/wftk/timer.h
-include/wftk-0.7/wftk/poll.h
-include/wftk-0.7/wftk/sdlhandler.h
-include/wftk-0.7/wftk/eventqueue.h
-include/wftk-0.7/wftk/messagebox.h
-include/wftk-0.7/wftk/questionbox.h
-include/wftk-0.7/wftk/fullscreendialog.h
-include/wftk-0.7/wftk/fixeddialog.h
-include/wftk-0.7/wftk/marshal.h
-include/wftk-0.7/wftk/mapinit.h
-include/wftk-0.7/wftk/string_hash_map.h
-include/wftk-0.7/wftk/version.h
-lib/libwftk-0.7.la
-lib/libwftk-0.7.so
-lib/libwftk-0.7.so.2
-libdata/pkgconfig/wftk-0.7.pc
-@dirrm include/wftk-0.7/wftk
-@dirrm include/wftk-0.7