aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/boost/Makefile2
-rw-r--r--devel/distorm/Makefile1
-rw-r--r--devel/dsss/Makefile2
-rw-r--r--devel/ifd-test/Makefile4
-rw-r--r--devel/leaktracer/Makefile3
-rw-r--r--devel/libdsp/Makefile3
-rw-r--r--devel/libmba/Makefile2
-rw-r--r--devel/libowfat/Makefile2
-rw-r--r--devel/libvolume_id/Makefile2
-rw-r--r--devel/luabind/Makefile3
-rw-r--r--devel/mpatrol/Makefile3
-rw-r--r--devel/newt/Makefile2
-rw-r--r--devel/picprog/Makefile2
-rw-r--r--devel/pikdev/Makefile2
-rw-r--r--devel/premake/Makefile1
-rw-r--r--devel/pwlib/Makefile6
-rw-r--r--devel/py-distorm/Makefile1
-rw-r--r--devel/sdl_sge/Makefile1
-rw-r--r--devel/stlport/Makefile1
-rw-r--r--devel/tcltls/Makefile2
-rw-r--r--devel/tokamak/Makefile1
21 files changed, 16 insertions, 30 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index 1e55536c7872..10a0bfcbb445 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -19,8 +19,6 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/./_/g}
-MAKE_ENV+= CXX=${CXX} CC=${CC}
-
.if defined(WITH_PYTHON) || defined (WITH_PYSTE)
USE_PYTHON= 2.4+
diff --git a/devel/distorm/Makefile b/devel/distorm/Makefile
index 5c23733f3dff..0a1fad00b52b 100644
--- a/devel/distorm/Makefile
+++ b/devel/distorm/Makefile
@@ -18,7 +18,6 @@ COMMENT= Fast x86 and x86-64 disassembler library
USE_BZIP2= yes
USE_LDCONFIG= yes
-MAKE_ENV+= CC=${CC}
WRKSRC= ${WRKDIR}/distorm/build/linux
ALL_TARGET= clib
PLIST_FILES= bin/disasm lib/libdistorm64.a lib/libdistorm64.so
diff --git a/devel/dsss/Makefile b/devel/dsss/Makefile
index 03cde3b44661..c94313bfdf65 100644
--- a/devel/dsss/Makefile
+++ b/devel/dsss/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= gdc:${PORTSDIR}/lang/gdc
USE_BZIP2= yes
MAKEFILE= Makefile.gdc.posix
-MAKE_ENV= CXX="${CXX}" NATIVECXX="${CXX}"
+MAKE_ENV= NATIVECXX="${CXX}"
PORTDOCS= *
diff --git a/devel/ifd-test/Makefile b/devel/ifd-test/Makefile
index a6c194f40d83..4d90807bb446 100644
--- a/devel/ifd-test/Makefile
+++ b/devel/ifd-test/Makefile
@@ -20,8 +20,8 @@ USE_GMAKE= yes
NOMAN=
PLIST_FILES= sbin/ifdtest
-MAKE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="-L${PREFIX}/lib -lpcsclite ${PTHREAD_LIBS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+MAKE_ENV= LIBS="-L${PREFIX}/lib -lpcsclite ${PTHREAD_LIBS}"
post-patch:
${REINPLACE_CMD} -e "s,LPSTR,LPTSTR,g; s,LPCSTR,LPCTSTR,g" \
diff --git a/devel/leaktracer/Makefile b/devel/leaktracer/Makefile
index 23222389cf52..bd42522bbe4c 100644
--- a/devel/leaktracer/Makefile
+++ b/devel/leaktracer/Makefile
@@ -18,8 +18,7 @@ COMMENT= Trace and analyze memory leaks in C++ programs
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_PERL5_RUN= yes
-MAKE_ENV= CXX="${CXX}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_FILES= bin/LeakCheck bin/leak-analyze lib/LeakTracer.so
PORTDOCS= README README.html
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 74b31e224f66..96fcf3561d81 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -21,8 +21,7 @@ WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
USE_AUTOTOOLS= libtool:15:env
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" MKDIR="${MKDIR}" \
- INLINE_VER="${INLINE_VER}"
+MAKE_ENV= MKDIR="${MKDIR}" INLINE_VER="${INLINE_VER}"
MAKEFILE= Makefile.FreeBSD
USE_LDCONFIG= yes
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index 59631c6d52cc..dec240e70781 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -19,7 +19,7 @@ COMMENT= A collection of C modules potentially useful to any project
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_GMAKE= yes
-MAKE_ENV= prefix="${PREFIX}" CC="${CC}" \
+MAKE_ENV= prefix="${PREFIX}" \
MINVERSION="${SHLIB_MAJOR}" \
RPM_OPT_FLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index c50f6e6cf45b..33c9fcff6a58 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -22,7 +22,7 @@ OPTIONS= LIBOWFAT_OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
.include <bsd.port.pre.mk>
-MAKE_ENV+= INSTALL="${INSTALL}" CC="${CC}"
+MAKE_ENV+= INSTALL="${INSTALL}"
.if defined(WITH_LIBOWFAT_OPTIMIZED_CFLAGS)
CFLAGS+= -O2 -fomit-frame-pointer
diff --git a/devel/libvolume_id/Makefile b/devel/libvolume_id/Makefile
index 06487905df37..f3fcd4644c2f 100644
--- a/devel/libvolume_id/Makefile
+++ b/devel/libvolume_id/Makefile
@@ -17,7 +17,7 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
MAKE_ENV= E=${ECHO_MSG} RANLIB=${RANLIB} AR=${AR} Q=@ \
- CC=${CC} prefix=${PREFIX}
+ prefix=${PREFIX}
PLIST_FILES= include/libvolume_id.h \
lib/libvolume_id.a \
diff --git a/devel/luabind/Makefile b/devel/luabind/Makefile
index e15e9d69003d..cb8bff0014db 100644
--- a/devel/luabind/Makefile
+++ b/devel/luabind/Makefile
@@ -20,8 +20,7 @@ USE_ZIP= yes
USE_LUA= 5.0
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" LUA_INCDIR="${LUA_INCDIR}" \
- BOOST_ROOT="${LOCALBASE}/include"
+MAKE_ENV= BOOST_ROOT="${LOCALBASE}/include"
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/mpatrol/Makefile b/devel/mpatrol/Makefile
index e1ed6d2d6944..d123e994910f 100644
--- a/devel/mpatrol/Makefile
+++ b/devel/mpatrol/Makefile
@@ -22,8 +22,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_LDCONFIG= yes
USE_GMAKE= yes
-MAKE_ENV= LOCALBASE="${LOCALBASE}" CXX="${CXX}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAN1= hexwords.1 mleak.1 mpatrol.1 mprof.1 \
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index cd7bb1b093a8..19db147f75e8 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -25,7 +25,7 @@ USE_LDCONFIG= yes
SOVERSION= 51
TCL_VERSION?= tcl8.3
TCL_NODOT= ${TCL_VERSION:S/.//}
-MAKE_ENV+= CC=${CC} PCFLAGS="${CFLAGS}" TCLVERSION="${TCL_VERSION}"
+MAKE_ENV+= PCFLAGS="${CFLAGS}" TCLVERSION="${TCL_VERSION}"
PLIST_SUB+= SOVERSION=${SOVERSION} \
EXAMPLESDIR="${EXAMPLESDIR:S,${PREFIX}/,,}"
diff --git a/devel/picprog/Makefile b/devel/picprog/Makefile
index 5cf77a9ea0b6..705bda450f33 100644
--- a/devel/picprog/Makefile
+++ b/devel/picprog/Makefile
@@ -15,7 +15,7 @@ COMMENT= Serial port pic16c84 programmer
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/picprog
MAN1= picprog.1
diff --git a/devel/pikdev/Makefile b/devel/pikdev/Makefile
index b726cc7770d2..94daeca75cad 100644
--- a/devel/pikdev/Makefile
+++ b/devel/pikdev/Makefile
@@ -30,7 +30,7 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}"
CONFIGURE_ARGS+= --with-pic=yes
-MAKE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}"
+MAKE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
SUB_FILES= pkg-message
OPTIONS= DEBUG "Enable debug information" off \
diff --git a/devel/premake/Makefile b/devel/premake/Makefile
index 7f03b6a26c13..95fe1269566c 100644
--- a/devel/premake/Makefile
+++ b/devel/premake/Makefile
@@ -19,7 +19,6 @@ WRKSRC= ${WRKDIR}/Premake-${PORTVERSION}
USE_DOS2UNIX= yes
USE_ZIP= yes
USE_GMAKE= yes
-MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
PLIST_FILES= bin/premake
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index aebb23a900da..e97d54798fea 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -32,14 +32,14 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+CFLAGS= -O1
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- CFLAGS="${CFLAGS} -O1"
+ CFLAGS="${CFLAGS}"
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- STDCCFLAGS+="-I${LOCALBASE}" \
- CFLAGS="${CFLAGS} -O1"
+ STDCCFLAGS+="-I${LOCALBASE}"
.if ${OSVERSION} >= 700042
CONFIGURE_ENV+= ATOMICITY_H="<ext/atomicity.h>"
diff --git a/devel/py-distorm/Makefile b/devel/py-distorm/Makefile
index caefb3541cd5..df09952788af 100644
--- a/devel/py-distorm/Makefile
+++ b/devel/py-distorm/Makefile
@@ -21,7 +21,6 @@ COMMENT= Fast x86 and x86-64 disassembler library with Python interface
USE_BZIP2= yes
USE_PYTHON= yes
-MAKE_ENV+= CC=${CC}
WRKSRC= ${WRKDIR}/distorm/build/linux
ALL_TARGET= py
PLIST_FILES= %%PYTHON_SITELIBDIR%%/distorm.so \
diff --git a/devel/sdl_sge/Makefile b/devel/sdl_sge/Makefile
index 18a8e8167a23..383b1d0551c8 100644
--- a/devel/sdl_sge/Makefile
+++ b/devel/sdl_sge/Makefile
@@ -18,7 +18,6 @@ COMMENT= A graphic library for the Simple DirectMedia Layer (SDL)
USE_GMAKE= yes
USE_LDCONFIG= yes
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
OPTIONS= SDL_IMAGE "Enable support for SDL_IMAGE" On \
FREETYPE "Enable FreeType support" On \
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index ef6f1466c3aa..ceeddc8bd16e 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -24,7 +24,6 @@ USE_GMAKE= yes
COMPILER?= gcc
MAKEFILE= ${COMPILER}.mak
ALL_TARGET= install
-MAKE_ENV+= CC=${CC} CXX=${CXX}
MAKE_ARGS+= INSTALLDIR=${PREFIX} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
PLIST_SUB+= COMPILER=${COMPILER} VER=${PORTVERSION} V2=${PORTVERSION:R} \
diff --git a/devel/tcltls/Makefile b/devel/tcltls/Makefile
index 174700f7e4eb..f5b1efae7b85 100644
--- a/devel/tcltls/Makefile
+++ b/devel/tcltls/Makefile
@@ -26,8 +26,6 @@ PLIST_SUB+= TCL_VER=${TCL_VER} DISTNAME="${DISTNAME}"
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV= TCL_VER=${TCL_VER} MKDIR="${MKDIR}" \
INSTALL_DATA="${INSTALL_DATA}" \
- OPENSSLINC="${OPENSSLINC}" OPENSSLLIB="${OPENSSLLIB}" \
- OPENSSLDIR="${OPENSSLDIR}" CFLAGS="${CFLAGS}" \
SHLIB_NAME=libtls.so.1 \
PORTVERSION="${PORTVERSION}" SED="${SED}"
REINPLACE_ARGS= -i ""
diff --git a/devel/tokamak/Makefile b/devel/tokamak/Makefile
index b47235756005..9a5db6b40bd9 100644
--- a/devel/tokamak/Makefile
+++ b/devel/tokamak/Makefile
@@ -19,7 +19,6 @@ USE_ZIP= yes
USE_GMAKE= yes
USE_DOS2UNIX= *
-MAKE_ENV= CC=${CC} CXX=${CXX}
MAKEFILE= tokamak.make
ALL_TARGET=
f='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/vietnamese?h=gstreamer0.10-removal&id=55830855d289d186b3feb68e46c795d3e9bf6091'>Normalize Aspell dictionaries PKGNAMEs.thierry2007-01-141-0/+1 * Add vietunicode-trichlor 2004.04.30, 100% Viet Unicode compatible.rafan2007-01-084-0/+69 * Add vietunicode-hannom 2005.02.06, UNICODE Han Nom Font Set.rafan2007-01-084-0/+50 * Add vietunicode-web1 2004.04.30, 100% Viet Unicode & Vietrafan2007-01-084-0/+53 * Update to KDE 3.5.5 / KOffice 1.6.1lofi2006-12-201-3/+3 * - Respect X11BASErafan2006-12-022-15/+12 * KDE 3.5.4 / KOffice 1.5.2lofi2006-09-132-3/+6 * All dictionaries can be installed separately:thierry2006-07-154-7/+18 * Update to KDE 3.5.3lofi2006-06-063-162/+100 * SHA256ifyedwin2006-01-2414-0/+16 * Update to KDE 3.5.0lofi2006-01-091-0/+1 * Remove expired ports.lawrance2005-12-155-73/+0 * Bump PORTREVISION to chase the glib20 shared library update.marcus2005-11-051-0/+1 * Unbreak by fixing pkg-plist and aligning run-depends statement.edwin2005-11-042-8/+5 * Unbreak port by fixing pkg-plistedwin2005-11-042-5/+2 * Respect X11BASEmnag2005-10-273-11/+26 * Mark as BROKEN: unfetchable.linimon2005-10-121-1/+5 * Update to KDE 3.4.2 / KOffice 1.4.1lofi2005-08-011-1/+1 * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-232-0/+4 * The grand-daddy site of VietNet gone :~-( R.I.P. media.mit.eduobrien2005-07-171-1/+2 * Watch over this VN port.obrien2005-07-171-1/+1 * The grand-daddy site of VietNet gone :~-( R.I.P. media.mit.eduobrien2005-07-175-10/+6 * The grand-daddy site of VietNet gone :~-( R.I.P. media.mit.eduobrien2005-07-171-2/+1 * Move to using the bzip2'ed distfile.obrien2005-07-172-2/+3 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-111-1/+1 * BROKEN: Broken dependencykris2005-03-271-0/+2 * Upgrade to 0.2.9.thierry2005-03-164-10/+10 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-0/+1 * BROKEN: Incomplete pkg-plistkris2005-02-281-0/+2 * Add ports to ${SUBDIR} in alphabetical order.cperciva2005-01-301-2/+2 * Portlint.obrien2004-12-302-2/+2 * Portlint.obrien2004-12-301-1/+1 * Add xvnkb 0.2.8, a Vietnamese input method for X-Window.thierry2004-12-3010-0/+306 * Update to KDE 3.3.2lofi2004-12-141-1/+1 * Update to KDE 3.3lofi2004-08-311-1/+1 * Add slaves ports for Aspell's new dictionaries.thierry2004-08-293-0/+22 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-243-20/+10 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * SIZEify (maintainer timeout)trevor2004-03-3113-0/+14 * Update to KDE 3.2.1 / QT 3.3.1lofi2004-03-102-2/+1 * - rpm2cpio.pl need to be EXTRACT_DEPENDS otherwise it will not workpav2004-03-021-1/+1 * Update to KDE 3.2.0lofi2004-02-053-5/+6 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-2/+2 * Now gettext 0.12.1 is gettext-old.trevor2004-01-241-1/+1 * Use the CPIO macro defined in bsd.port.mk.trevor2004-01-221-1/+1 * Use the SORT macro from bsd.port.mk.trevor2004-01-221-1/+1 * s/rpm2cpio/rpm2cpio.pl/ after the recent update of archivers/rpm2cpio (thenetchild2003-12-121-2/+2 * Another last minute change. Size/date stamp changes only.will2003-09-281-1/+1 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-181-2/+1 * Update this port from being based on the X11 R6.5.1 sources to R6.6.obrien2003-08-182-3/+4