aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/dmake/Makefile3
-rw-r--r--devel/dmake/files/patch-configure35
-rw-r--r--devel/dmake/files/patch-warnings15
3 files changed, 37 insertions, 16 deletions
diff --git a/devel/dmake/Makefile b/devel/dmake/Makefile
index 1daaae9f940b..fad327ad729a 100644
--- a/devel/dmake/Makefile
+++ b/devel/dmake/Makefile
@@ -7,8 +7,9 @@
PORTNAME= dmake
PORTVERSION= 4.3
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= http://people.debian.org/~rene/dmake/
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTFILES= ${PORTNAME}_${PORTVERSION}.orig.tar.gz
MAINTAINER= ports@FreeBSD.org
diff --git a/devel/dmake/files/patch-configure b/devel/dmake/files/patch-configure
new file mode 100644
index 000000000000..73c9b69f4500
--- /dev/null
+++ b/devel/dmake/files/patch-configure
@@ -0,0 +1,35 @@
+--- configure.orig Tue Oct 12 21:47:46 2004
++++ configure Fri Mar 24 22:06:28 2006
+@@ -6206,12 +6206,13 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
++#include <utime.h>
+ int
+ main ()
+ {
+ struct stat s, t;
+ exit (!(stat ("conftest.data", &s) == 0
+- && utime ("conftest.data", (long *)0) == 0
++ && utime ("conftest.data", (void *)0) == 0
+ && stat ("conftest.data", &t) == 0
+ && t.st_mtime >= s.st_mtime
+ && t.st_mtime - s.st_mtime < 120));
+@@ -6669,7 +6670,7 @@
+
+
+ if test "${prefix}" != NONE; then
+- DMAKEROOT=${prefix}/share/startup/startup.mk
++ DMAKEROOT=${prefix}/share/dmake/startup/startup.mk
+ export DMAKEROOT
+ else
+ DMAKEROOT=startup.mk
+@@ -8108,7 +8109,7 @@
+
+ if test x$prefix != x; then
+ if test x$OS_TYPE = xunix; then
+- echo '"DMAKEROOT := '$prefix'/share/startup",' >> $outfile
++ echo '"DMAKEROOT := '$prefix'/share/dmake/startup",' >> $outfile
+ fi
+ echo '"OS := '${OS_VERSION}'",' >> $outfile
+ fi
diff --git a/devel/dmake/files/patch-warnings b/devel/dmake/files/patch-warnings
index 8202e8fb6d9d..b8e95b36da94 100644
--- a/devel/dmake/files/patch-warnings
+++ b/devel/dmake/files/patch-warnings
@@ -126,18 +126,3 @@ most common.
+ /* char *newtmp; */
/* This call to Get_temp sets TMPFILE for subsequent expansion of file.
---- configure Fri Oct 22 05:36:37 2004 -- fix warnings, so configure does
-+++ configure Sun Jan 2 19:07:52 2005 -- not conclude, our utime is bad.
-@@ -6207,4 +6207,5 @@
- /* end confdefs.h. */
- $ac_includes_default
-+#include <utime.h>
- int
- main ()
-@@ -6212,5 +6213,5 @@
- struct stat s, t;
- exit (!(stat ("conftest.data", &s) == 0
-- && utime ("conftest.data", (long *)0) == 0
-+ && utime ("conftest.data", (void *)0) == 0
- && stat ("conftest.data", &t) == 0
- && t.st_mtime >= s.st_mtime