aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-gnustep/Makefile6
-rw-r--r--devel/ruby-pcsc-lite/Makefile9
-rw-r--r--devel/ruby-sdl/Makefile5
3 files changed, 15 insertions, 5 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 6179beddb636..34f9d317a74c 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnustep
PORTVERSION= 0.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel ruby
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/libs/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -36,7 +36,6 @@ RUN_DEPENDS+= ${COMBOLIBDIR}/libobjc.so:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
.endif
USE_RUBY= yes
-RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
CC= gcc32
CXX= g++32
@@ -60,6 +59,9 @@ COMBOLIBDIR= ${SYSLIBDIR}
MAKE_ENV+= GNUSTEP_FLATTENED=yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
diff --git a/devel/ruby-pcsc-lite/Makefile b/devel/ruby-pcsc-lite/Makefile
index 931dbf1fcd32..2a2d33a5939a 100644
--- a/devel/ruby-pcsc-lite/Makefile
+++ b/devel/ruby-pcsc-lite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pcsc-lite
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= devel ruby
MASTER_SITES= http://soth.at/PCSC-ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -20,7 +21,6 @@ LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
USE_RUBY= yes
RUBY_VER= 1.8
-RUBY_WITH_PTHREAD= yes
CONFIGURE_ARGS+= --with-pcsclite-dir="${PREFIX}"
USE_RUBY_EXTCONF= yes
RUBY_SETUP= install.rb
@@ -30,6 +30,11 @@ WRKSRC= ${WRKDIR}/PCSC-ruby
DOCS= README.txt
EXAMPLES= examples/test.rb examples/pcsclient.rb
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}/
@@ -42,4 +47,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index 648ad9fd9508..8f8addfb9f1d 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= devel graphics audio ruby
MASTER_SITES= http://www.kmc.gr.jp/~ohai/rubysdl/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -24,7 +25,6 @@ RUBY_OPENGL_WRKSRC_CMD= cd ${RUBY_OPENGL_PORTDIR}; ${MAKE} -V WRKSRC
USE_SDL= mixer image ttf sdl
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-RUBY_WITH_PTHREAD= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
--enable-opengl --linkoglmodule \
@@ -42,6 +42,9 @@ DOCS_JA= NEWS.ja README.ja \
${RUBY_RD_HTML_FILES:N*.en.html}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
post-extract:
dir=`${RUBY_OPENGL_WRKSRC_CMD}`; \