aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/stack/Makefile7
-rw-r--r--devel/stack/files/patch-Makefile11
2 files changed, 17 insertions, 1 deletions
diff --git a/devel/stack/Makefile b/devel/stack/Makefile
index fc1494f2349c..882c28158afa 100644
--- a/devel/stack/Makefile
+++ b/devel/stack/Makefile
@@ -10,6 +10,7 @@
PORTNAME= stack
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= GH \
https://github.com/applicative-tech/stack-dependencies/releases/download/${PORTVERSION}/:deps
@@ -30,7 +31,11 @@ LIB_DEPENDS= libiconv.so:converters/libiconv \
RUN_DEPENDS+= gcc:lang/gcc
LIB_DEPENDS+= libutil.so.8:misc/compat8x
-USES= gmake
+# Needed for 'stack setup'
+RUN_DEPENDS+= ca_root_nss>0:security/ca_root_nss \
+ gmake:devel/gmake
+USES= gmake perl5
+
USE_GITHUB= yes
GH_ACCOUNT= applicative-tech
GH_PROJECT= stack-dependencies
diff --git a/devel/stack/files/patch-Makefile b/devel/stack/files/patch-Makefile
new file mode 100644
index 000000000000..43ee97121276
--- /dev/null
+++ b/devel/stack/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-07-23 16:05:37 UTC
++++ Makefile
+@@ -34,7 +34,7 @@ _stack.zsh: _stack.bash
+ # zsh completion reuses bash completion file via zsh's bashcompinit function
+ ${ECHO} "#compdef stack" > ${@}
+ ${ECHO} "autoload -U +X bashcompinit && bashcompinit" >> ${@}
+- ${CAT} ${>} >> ${@}
++ ${CAT} _stack.bash >> ${@}
+
+ install: all
+ ${INSTALL_PROGRAM} stack ${STAGEDIR}${PREFIX}/bin