aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/linguist/Makefile8
-rw-r--r--devel/moonshine/Makefile18
2 files changed, 19 insertions, 7 deletions
diff --git a/devel/linguist/Makefile b/devel/linguist/Makefile
index 0f9cd20f3bb0..6115102291c8 100644
--- a/devel/linguist/Makefile
+++ b/devel/linguist/Makefile
@@ -28,6 +28,12 @@ MAKE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
MOC="${X11BASE}/bin/moc2"
MAKE_ARGS= -e
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
post-configure:
@${PERL} -pi -e 's|\$\(SUBDIRS\):.*tmake_all|\$\(SUBDIRS\):|' \
${WRKSRC}/Makefile
@@ -41,4 +47,4 @@ do-install:
${MKDIR} ${PREFIX}/share/doc/linguist
${INSTALL_MAN} ${WRKSRC}/linguist/tutorial/doc/html/* ${PREFIX}/share/doc/linguist
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/moonshine/Makefile b/devel/moonshine/Makefile
index d60d5a16fbad..76c5424effd8 100644
--- a/devel/moonshine/Makefile
+++ b/devel/moonshine/Makefile
@@ -21,11 +21,17 @@ CPPFLAGS+= -I${X11BASE}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-configure:
- @ find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\{prefix\}/moonshine|\$$\{prefix\}/share/moonshine| ; \
- s|\@INSTBIN\@|${PREFIX}/bin| ; s|moc -o|\$$\(MOC\) -o|'
- @ ${PERL} -pi -e 's|/usr/share/moonshine|${PREFIX}/share/moonshine|' \
- ${WRKSRC}/include/tags.h
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\{prefix\}/moonshine|\$$\{prefix\}/share/moonshine| ; \
+ s|\@INSTBIN\@|${PREFIX}/bin| ; s|moc -o|\$$\(MOC\) -o|'
+ @${PERL} -pi -e 's|/usr/share/moonshine|${PREFIX}/share/moonshine|' \
+ ${WRKSRC}/include/tags.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>