aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/log4cxx/Makefile46
-rw-r--r--devel/log4cxx/files/patch-include-clocale-and-cstdlib24
2 files changed, 43 insertions, 27 deletions
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index 82b8c7dd7861..7640d000066b 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -10,46 +10,38 @@ MASTER_SITE_SUBDIR= logging/${PORTNAME}/${PORTVERSION}
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Log4cxx is a port to C++ of the Log4j project
+COMMENT= C++ port of the Log4j project
LICENSE= AL2
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1
-OPTIONS_DEFINE= BOOST DOCS DOXYGEN
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
-.else
-CONFIGURE_ARGS+= --disable-doxygen
-.endif
-
-.if ${PORT_OPTIONS:MBOOST}
-BUILD_DEPENDS+= ${LOCALBASE}/include/boost/regex.hpp:${PORTSDIR}/devel/boost-libs
-.endif
-
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:env autoconf:env libtool:env
-
+USES= pathfix
+USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-USE_LDCONFIG= yes
+OPTIONS_DEFINE= BOOST DOXYGEN
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
-PORTDOCS= *
-.endif
+BOOST_BUILD_DEPENDS= ${LOCALBASE}/include/boost/regex.hpp:${PORTSDIR}/devel/boost-libs
+
+DOXYGEN_CONFIGURE_OFF= --disable-doxygen
+DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+
+.include <bsd.port.options.mk>
-USES= pathfix
+post-configure:
+ @${REINPLACE_CMD} -e 's|-dpR|-pr|' \
+ -e '/^htmldest/ s|$$(pkgdatadir)|${DOCSDIR}|' \
+ ${WRKSRC}/src/site/doxy/Makefile
post-install:
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
- ${MKDIR} ${DOCSDIR}
- for f in ${PORTDOCS}; do \
- ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
- done
+.if ${PORT_OPTIONS:MDOXYGEN}
+ @cd ${STAGEDIR}${PREFIX} && \
+ ${FIND} ${DOCSDIR:S|${PREFIX}/||} ! -type d >> ${TMPPLIST} && \
+ ${FIND} ${DOCSDIR:S|${PREFIX}/||} -type d | ${SORT} -r | \
+ ${SED} 's|^|@dirrm |' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>
diff --git a/devel/log4cxx/files/patch-include-clocale-and-cstdlib b/devel/log4cxx/files/patch-include-clocale-and-cstdlib
new file mode 100644
index 000000000000..3e9fb6829f43
--- /dev/null
+++ b/devel/log4cxx/files/patch-include-clocale-and-cstdlib
@@ -0,0 +1,24 @@
+--- src/main/cpp/stringhelper.cpp 2008-04-01 00:34:09.000000000 +0200
++++ src/main/cpp/stringhelper.cpp 2013-11-22 11:27:50.000000000 +0100
+@@ -28,6 +28,7 @@
+ #endif
+ #include <log4cxx/private/log4cxx_private.h>
+ #include <cctype>
++#include <cstdlib>
+ #include <apr.h>
+
+
+--- src/main/include/log4cxx/helpers/simpledateformat.h 2008-04-01 00:34:26.000000000 +0200
++++ src/main/include/log4cxx/helpers/simpledateformat.h 2013-11-22 11:27:27.000000000 +0100
+@@ -27,10 +27,9 @@
+
+ #include <log4cxx/helpers/dateformat.h>
+ #include <vector>
++#include <locale>
+ #include <time.h>
+
+-namespace std { class locale; }
+-
+ namespace log4cxx
+ {
+ namespace helpers