aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Carp/Makefile21
-rw-r--r--devel/p5-Carp/distinfo2
-rw-r--r--devel/p5-Carp/pkg-descr8
-rw-r--r--devel/p5-Carp/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e4101e6f65d7..a9423730ad63 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1342,6 +1342,7 @@
SUBDIR += p5-Cairo-GObject
SUBDIR += p5-Calendar-Simple
SUBDIR += p5-Capture-Tiny
+ SUBDIR += p5-Carp
SUBDIR += p5-Carp-Always
SUBDIR += p5-Carp-Always-Color
SUBDIR += p5-Carp-Assert
diff --git a/devel/p5-Carp/Makefile b/devel/p5-Carp/Makefile
new file mode 100644
index 000000000000..3a46bdf725a0
--- /dev/null
+++ b/devel/p5-Carp/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Carp
+# Date created: 2012-04-02
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Carp
+PORTVERSION= 1.25
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Alternative warn and die for modules
+
+PERL_CONFIGURE= yes
+
+MAN3= Carp.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Carp/distinfo b/devel/p5-Carp/distinfo
new file mode 100644
index 000000000000..95a233e3ce12
--- /dev/null
+++ b/devel/p5-Carp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Carp-1.25.tar.gz) = e4642869061a9e5f94c4a642d9d8527ad5e4c5b8c840f6fbcc56256205c8cd46
+SIZE (Carp-1.25.tar.gz) = 12410
diff --git a/devel/p5-Carp/pkg-descr b/devel/p5-Carp/pkg-descr
new file mode 100644
index 000000000000..34fdd600ae02
--- /dev/null
+++ b/devel/p5-Carp/pkg-descr
@@ -0,0 +1,8 @@
+The Carp routines are useful in your own modules because they act like die() or
+warn(), but with a message which is more likely to be useful to a user of your
+module. In the case of cluck, confess, and longmess that context is a summary of
+every call in the call-stack. For a shorter message you can use carp or croak
+which report the error as being from where your module was called. There is no
+guarantee that that is where the error was, but it is a good educated guess.
+
+WWW: http://search.cpan.org/dist/Carp/
diff --git a/devel/p5-Carp/pkg-plist b/devel/p5-Carp/pkg-plist
new file mode 100644
index 000000000000..0a24b6c19560
--- /dev/null
+++ b/devel/p5-Carp/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Carp.pm
+%%SITE_PERL%%/Carp/Heavy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp
+@dirrmtry %%SITE_PERL%%/Carp