aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyrfc3339/Makefile23
-rw-r--r--devel/py-pyrfc3339/distinfo2
-rw-r--r--devel/py-pyrfc3339/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 50c89db9197a..48e926fda74a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4045,6 +4045,7 @@
SUBDIR += py-pympler
SUBDIR += py-pymtbl
SUBDIR += py-pyparsing15
+ SUBDIR += py-pyrfc3339
SUBDIR += py-pyro
SUBDIR += py-pyshapelib
SUBDIR += py-pytemplate
diff --git a/devel/py-pyrfc3339/Makefile b/devel/py-pyrfc3339/Makefile
new file mode 100644
index 000000000000..6775f480e454
--- /dev/null
+++ b/devel/py-pyrfc3339/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyrfc3339
+PORTVERSION= 0.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyRFC3339-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Generate and parse RFC 3339 timestamps
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:${PORTSDIR}/devel/py-nose
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyrfc3339/distinfo b/devel/py-pyrfc3339/distinfo
new file mode 100644
index 000000000000..8bc9babd5a31
--- /dev/null
+++ b/devel/py-pyrfc3339/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyRFC3339-0.2.tar.gz) = a504ff6bcb363fa402d393f65fe5f542475e54fbfc55817b80892ba93b22e6de
+SIZE (pyRFC3339-0.2.tar.gz) = 5068
diff --git a/devel/py-pyrfc3339/pkg-descr b/devel/py-pyrfc3339/pkg-descr
new file mode 100644
index 000000000000..96c154d3cea6
--- /dev/null
+++ b/devel/py-pyrfc3339/pkg-descr
@@ -0,0 +1,5 @@
+pyRFC3339 parses and generates RFC 3339-compliant timestamps using Python
+datetime.datetime objects.
+
+WWW: https://pypi.python.org/pypi/pyRFC3339
+WWW: https://github.com/kurtraschke/pyRFC3339