aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/sfml/Makefile5
-rw-r--r--devel/sfml/pkg-plist5
2 files changed, 9 insertions, 1 deletions
diff --git a/devel/sfml/Makefile b/devel/sfml/Makefile
index 31654e1ebbe3..27ee367b40f4 100644
--- a/devel/sfml/Makefile
+++ b/devel/sfml/Makefile
@@ -36,8 +36,11 @@ post-extract:
@${RM} -f ${WRKSRC}/lib/*
@${FIND} ${WRKSRC}/samples/bin/ -type f -maxdepth 1 -delete
-.if !defined(NOPORTDOCS)
post-install:
+.for lib in audio graphics network system window
+ @${LN} -s libsfml-${lib}.so.${PORTVERSION} ${PREFIX}/lib/libsfml-${lib}.so.${PORTVERSION:C/^([0-9]).*/\1/}
+.endfor
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "*" ${DOCSDIR}/
.endif
diff --git a/devel/sfml/pkg-plist b/devel/sfml/pkg-plist
index 7149dce24159..ed5b7a6bf7f7 100644
--- a/devel/sfml/pkg-plist
+++ b/devel/sfml/pkg-plist
@@ -72,14 +72,19 @@ include/SFML/Window/WindowListener.hpp
include/SFML/Window/WindowSettings.hpp
include/SFML/Window/WindowStyle.hpp
lib/libsfml-audio.so
+lib/libsfml-audio.so.1
lib/libsfml-audio.so.1.6
lib/libsfml-graphics.so
+lib/libsfml-graphics.so.1
lib/libsfml-graphics.so.1.6
lib/libsfml-network.so
+lib/libsfml-network.so.1
lib/libsfml-network.so.1.6
lib/libsfml-system.so
+lib/libsfml-system.so.1
lib/libsfml-system.so.1.6
lib/libsfml-window.so
+lib/libsfml-window.so.1
lib/libsfml-window.so.1.6
@dirrm include/SFML/Window
@dirrm include/SFML/System/Win32