aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Import-Base/Makefile28
-rw-r--r--devel/p5-Import-Base/distinfo2
-rw-r--r--devel/p5-Import-Base/pkg-descr6
-rw-r--r--devel/p5-Import-Base/pkg-plist2
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e484024125b..550054bc6386 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2464,6 +2464,7 @@
SUBDIR += p5-IPC-ShellCmd
SUBDIR += p5-IPC-Signal
SUBDIR += p5-IPC-System-Simple
+ SUBDIR += p5-Import-Base
SUBDIR += p5-Import-Into
SUBDIR += p5-Inline
SUBDIR += p5-Inline-ASM
diff --git a/devel/p5-Import-Base/Makefile b/devel/p5-Import-Base/Makefile
new file mode 100644
index 000000000000..f89b20c8e306
--- /dev/null
+++ b/devel/p5-Import-Base/Makefile
@@ -0,0 +1,28 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Import-Base
+PORTVERSION= 1.001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PREACTION
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Import a set of modules into the calling module
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Import-Into>=1.002005:${PORTSDIR}/devel/p5-Import-Into \
+ p5-Module-Runtime>=0:${PORTSDIR}/devel/p5-Module-Runtime
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Dancer2-Plugin-Ajax>=0:${PORTSDIR}/www/p5-Dancer2-Plugin-Ajax \
+ p5-Dancer2>=0:${PORTSDIR}/www/p5-Dancer2 \
+ p5-Moo>=0:${PORTSDIR}/devel/p5-Moo
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Import-Base/distinfo b/devel/p5-Import-Base/distinfo
new file mode 100644
index 000000000000..b8f7b987ae00
--- /dev/null
+++ b/devel/p5-Import-Base/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Import-Base-1.001.tar.gz) = ada5c0bba4106d23267a74daf8f0f1b8ee5defaf6ecbc19e3645596e528a5806
+SIZE (Import-Base-1.001.tar.gz) = 29604
diff --git a/devel/p5-Import-Base/pkg-descr b/devel/p5-Import-Base/pkg-descr
new file mode 100644
index 000000000000..1954c3ed3956
--- /dev/null
+++ b/devel/p5-Import-Base/pkg-descr
@@ -0,0 +1,6 @@
+This module makes it easier to build and manage a base set of imports. Rather
+than importing a dozen modules in each of your project's modules, you simply
+import one module and get all the other modules you want. This reduces your
+module boilerplate from 12 lines to 1.
+
+WWW: https://metacpan.org/pod/Import::Base
diff --git a/devel/p5-Import-Base/pkg-plist b/devel/p5-Import-Base/pkg-plist
new file mode 100644
index 000000000000..62a8cc1b2512
--- /dev/null
+++ b/devel/p5-Import-Base/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Import/Base.pm
+%%PERL5_MAN3%%/Import::Base.3.gz