aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ORBit2/Makefile7
-rw-r--r--devel/bonobo-activation/Makefile6
-rw-r--r--devel/bugbuddy2/Makefile6
-rw-r--r--devel/gconf2/Makefile7
-rw-r--r--devel/glib20/Makefile3
-rw-r--r--devel/gnome-vfs/Makefile6
-rw-r--r--devel/gnomevfs2/Makefile6
-rw-r--r--devel/gob2/Makefile4
-rw-r--r--devel/libIDL/Makefile4
-rw-r--r--devel/libbonobo/Makefile5
-rw-r--r--devel/libglade2/Makefile5
-rw-r--r--devel/libgsf/Makefile6
-rw-r--r--devel/libgtop2/Makefile5
-rw-r--r--devel/py-orbit2/Makefile4
14 files changed, 16 insertions, 58 deletions
diff --git a/devel/ORBit2/Makefile b/devel/ORBit2/Makefile
index 0d59a2460b5e..29311c0e02f3 100644
--- a/devel/ORBit2/Makefile
+++ b/devel/ORBit2/Makefile
@@ -15,20 +15,17 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= High-performance CORBA ORB with support for the C language
-LIB_DEPENDS= IDL-2.0:${PORTSDIR}/devel/libIDL \
- popt.0:${PORTSDIR}/devel/popt \
- linc.1:${PORTSDIR}/net/linc
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack libidl linc
CONFIGURE_ARGS= --disable-indent
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@find ${WRKSRC} -type f | xargs ${GREP} -l LINC_THREADSAFE | \
diff --git a/devel/bonobo-activation/Makefile b/devel/bonobo-activation/Makefile
index e449646633f8..ca74ed428eb0 100644
--- a/devel/bonobo-activation/Makefile
+++ b/devel/bonobo-activation/Makefile
@@ -16,13 +16,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An object activation framework for GNOME 2.0
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- ORBit-2.0:${PORTSDIR}/devel/ORBit2
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack libxml2 orrbit2
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_PERL5= yes
@@ -30,7 +27,6 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bonobo-activation-server.1
diff --git a/devel/bugbuddy2/Makefile b/devel/bugbuddy2/Makefile
index 1ece029b7abc..634be9a08431 100644
--- a/devel/bugbuddy2/Makefile
+++ b/devel/bugbuddy2/Makefile
@@ -16,17 +16,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A bug reporting tool for GNOME 2.0
-LIB_DEPENDS= gnome-desktop-2.3:${PORTSDIR}/x11/gnomedesktop
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack gnomedesktop
+GNOME_DESKTOP_VERSION=2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bug-buddy.1
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 9ae49dc6d813..141c365305f6 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -16,21 +16,16 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A configuration database system for GNOME
-LIB_DEPENDS= ORBit-2.0:${PORTSDIR}/devel/ORBit2 \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gnomehier
+USE_GNOME= gnomehack gnomehier orbit2 libxml2 gtk20
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 8cb0cbbe90b1..6e19919658f2 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -30,7 +30,7 @@ USE_BZIP2= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack gnometarget
USE_GMAKE= yes
USE_PERL5= yes
CONFIGURE_ARGS= --enable-static --with-libiconv=gnu
@@ -38,7 +38,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= glib-genmarshal.1 glib-mkenums.1
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 76e842858d42..323a1cfc5c1d 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -16,13 +16,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Virtual File System
-LIB_DEPENDS= gconf-2.5:${PORTSDIR}/devel/gconf2 \
- bonobo-2.0:${PORTSDIR}/devel/libbonobo
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier gnomemimedata
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomemimedata gconf2 libbonobo
USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -30,7 +27,6 @@ CONFIGURE_ARGS= --with-gconf-source=xml::${PREFIX}/etc/gconf/gconf.xml.defaults
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.pre.mk>
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 76e842858d42..323a1cfc5c1d 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -16,13 +16,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Virtual File System
-LIB_DEPENDS= gconf-2.5:${PORTSDIR}/devel/gconf2 \
- bonobo-2.0:${PORTSDIR}/devel/libbonobo
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier gnomemimedata
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomemimedata gconf2 libbonobo
USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -30,7 +27,6 @@ CONFIGURE_ARGS= --with-gconf-source=xml::${PREFIX}/etc/gconf/gconf.xml.defaults
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.pre.mk>
diff --git a/devel/gob2/Makefile b/devel/gob2/Makefile
index 9409d9bd514f..93ff3e171a5c 100644
--- a/devel/gob2/Makefile
+++ b/devel/gob2/Makefile
@@ -16,13 +16,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A preprocessor for making GObjects with inline C
-LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GNOME= glib20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gob2.1
diff --git a/devel/libIDL/Makefile b/devel/libIDL/Makefile
index 67be3d1b3065..fb92ed572620 100644
--- a/devel/libIDL/Makefile
+++ b/devel/libIDL/Makefile
@@ -16,18 +16,16 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A library for creating trees of CORBA Interface Definition Language files
-LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_GNOME= gnomehack
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+USE_GNOME= glib20
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index 1d4279a66c22..38faede2cbdc 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -15,20 +15,17 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A component and compound document system for GNOME2
-LIB_DEPENDS= bonobo-activation.4:${PORTSDIR}/devel/bonobo-activation
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack bonoboactivation
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale
.include <bsd.port.mk>
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index d5e22445ff79..fcadc845bb6f 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -18,8 +18,6 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME glade library
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
USE_BZIP2= yes
@@ -28,10 +26,9 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_LIBTOOL= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack libxml2 gtk20
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
index 4ae662aa0d55..7a7a74212d2d 100644
--- a/devel/libgsf/Makefile
+++ b/devel/libgsf/Makefile
@@ -15,18 +15,14 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An extensible i/o abstraction for dealing with structured file formats
-LIB_DEPENDS= bonobo-2.0:${PORTSDIR}/devel/libbonobo \
- gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
-
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack libbonobo gnomevfs2
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc/gsf \
--disable-gtk-doc --with-gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/devel/libgtop2/Makefile b/devel/libgtop2/Makefile
index cc1225598093..f10e573820b9 100644
--- a/devel/libgtop2/Makefile
+++ b/devel/libgtop2/Makefile
@@ -17,18 +17,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2.0 top library
-LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
-
USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack glib20
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-install:
install-info --section="Programming \& development tools" \
diff --git a/devel/py-orbit2/Makefile b/devel/py-orbit2/Makefile
index c8e7f0020ad1..69ae981ce0bc 100644
--- a/devel/py-orbit2/Makefile
+++ b/devel/py-orbit2/Makefile
@@ -16,11 +16,9 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python bindings for ORBit2
-LIB_DEPENDS= ORBit-2.0:${PORTSDIR}/devel/ORBit2
-
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack orbit2
USE_PYTHON= yes
USE_LIBTOOL= yes