aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/libmba/Makefile12
-rw-r--r--devel/libmba/pkg-plist22
2 files changed, 23 insertions, 11 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index cfac6e30ef0b..1688617908a4 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -9,20 +9,12 @@ MASTER_SITES= http://www.ioplex.com/~miallen/libmba/dl/ \
MASTER_SITE_SUBDIR= miwi
MAINTAINER= ports@FreeBSD.org
-COMMENT= A collection of C modules potentially useful to any project
+COMMENT= Collection of C modules potentially useful to any project
MAKE_JOBS_UNSAFE= yes
-PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
USE_LDCONFIG= yes
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
-MAN3= allocator.3m bitset.3m cfg.3m csv.3m diff.3m eval.3m hashmap.3m \
- hexdump.3m linkedlist.3m msgno.3m path.3m pool.3m shellout.3m \
- stack.3m suba.3m svcond.3m svsem.3m text.3m time.3m varray.3m
-MANCOMPRESSED= yes
-
-SHLIB_MAJOR= 0
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,-g,$$(CFLAGS),' \
-e '/^prefix/s/=/?=/' \
diff --git a/devel/libmba/pkg-plist b/devel/libmba/pkg-plist
index b2d16304c30c..a0d7a152fd08 100644
--- a/devel/libmba/pkg-plist
+++ b/devel/libmba/pkg-plist
@@ -24,5 +24,25 @@ include/mba/time.h
include/mba/varray.h
lib/libmba.a
lib/libmba.so
-lib/libmba.so.%%SHLIB_MAJOR%%
+lib/libmba.so.0
+man/man3/allocator.3m.gz
+man/man3/bitset.3m.gz
+man/man3/cfg.3m.gz
+man/man3/csv.3m.gz
+man/man3/diff.3m.gz
+man/man3/eval.3m.gz
+man/man3/hashmap.3m.gz
+man/man3/hexdump.3m.gz
+man/man3/linkedlist.3m.gz
+man/man3/msgno.3m.gz
+man/man3/path.3m.gz
+man/man3/pool.3m.gz
+man/man3/shellout.3m.gz
+man/man3/stack.3m.gz
+man/man3/suba.3m.gz
+man/man3/svcond.3m.gz
+man/man3/svsem.3m.gz
+man/man3/text.3m.gz
+man/man3/time.3m.gz
+man/man3/varray.3m.gz
@dirrm include/mba