aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/py-interface/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/devel/py-interface/Makefile b/devel/py-interface/Makefile
index e1f2aaf358be..afb765929581 100644
--- a/devel/py-interface/Makefile
+++ b/devel/py-interface/Makefile
@@ -9,7 +9,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py_${PORTNAME}-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-COMMENT= A Python implementation of an Erlang node
+COMMENT= Python implementation of an Erlang node
+
+LICENSE= GPLv2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -17,16 +19,15 @@ PYDISTUTILS_PKGNAME= py_${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/py_${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py_${PORTNAME}
-NO_STAGE= yes
post-install:
@${TRUE}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${INSTALL_DATA} * ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>