aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/boost/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index 6527b20cdd5d..72fdfa487814 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -66,7 +66,11 @@ WITH_PYTHON= IMPLIED_BY_PYSTE
# (this implies -DWITH_PYTHON).
#
.if defined(WITH_PYTHON)
+.if !defined(BOOST_GCC3_PORT)
PKGNAMESUFFIX= -python
+.else
+PKGNAMESUFFIX= -python-gcc3
+.endif
PLIST_SUB+= BOOST_PYTHON=""
MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
PYTHON_VERSION="${PYTHON_VERSION}"\