aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/fpc-bfd/Makefile5
-rw-r--r--devel/fpc-fcl-async/Makefile4
-rw-r--r--devel/fpc-fcl-base/Makefile10
-rw-r--r--devel/fpc-fcl-db/Makefile18
-rw-r--r--devel/fpc-fcl-fpcunit/Makefile12
-rw-r--r--devel/fpc-fcl-image/Makefile13
-rw-r--r--devel/fpc-fcl-net/Makefile13
-rw-r--r--devel/fpc-fcl-passrc/Makefile5
-rw-r--r--devel/fpc-fcl-registry/Makefile12
-rw-r--r--devel/fpc-fcl-web/Makefile20
-rw-r--r--devel/fpc-fcl-xml/Makefile11
-rw-r--r--devel/fpc-fpmkunit/Makefile4
-rw-r--r--devel/fpc-fv/Makefile5
-rw-r--r--devel/fpc-gconf/Makefile9
-rw-r--r--devel/fpc-gdbint/Makefile4
-rw-r--r--devel/fpc-pthreads/Makefile4
-rw-r--r--devel/fpc-regexpr/Makefile4
-rw-r--r--devel/fpc-zlib/Makefile5
18 files changed, 38 insertions, 120 deletions
diff --git a/devel/fpc-bfd/Makefile b/devel/fpc-bfd/Makefile
index 37544f36ac85..0d3649bd108d 100644
--- a/devel/fpc-bfd/Makefile
+++ b/devel/fpc-bfd/Makefile
@@ -5,15 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -bfd
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal interface for the GNU Binary Format description
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- fpcmake:${PORTSDIR}/lang/fpc-utils
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/extra/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fcl-async/Makefile b/devel/fpc-fcl-async/Makefile
index 6d8d7ca16421..3d5a0bcd5f8c 100644
--- a/devel/fpc-fcl-async/Makefile
+++ b/devel/fpc-fcl-async/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net lang
PKGNAMESUFFIX= -libasync
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal interface to async library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/base/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fcl-base/Makefile b/devel/fpc-fcl-base/Makefile
index 74d3f9cb9e0a..c79b6a27d90a 100644
--- a/devel/fpc-fcl-base/Makefile
+++ b/devel/fpc-fcl-base/Makefile
@@ -5,21 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-base
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads
+USE_FPC= libasync hash netdb paszlib pthreads
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-db/Makefile b/devel/fpc-fcl-db/Makefile
index c29a2442b509..68bcc33b6d7b 100644
--- a/devel/fpc-fcl-db/Makefile
+++ b/devel/fpc-fcl-db/Makefile
@@ -5,28 +5,16 @@
# $FreeBSD$
#
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-db
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
- ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
- ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
+USE_FPC= fcl-base hash ibase mysql netdb odbc oracle paszlib postgres pthreads \
+ libasync sqlite
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-fpcunit/Makefile b/devel/fpc-fcl-fpcunit/Makefile
index a313e649edec..e4c4da4f20d3 100644
--- a/devel/fpc-fcl-fpcunit/Makefile
+++ b/devel/fpc-fcl-fpcunit/Makefile
@@ -5,23 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-fpcunit
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads
+USE_FPC= fcl-base fcl-xml hash libasync netdb paszlib pthreads
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-image/Makefile b/devel/fpc-fcl-image/Makefile
index 57ebe359e088..ed7ab28963fb 100644
--- a/devel/fpc-fcl-image/Makefile
+++ b/devel/fpc-fcl-image/Makefile
@@ -5,24 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-image
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/libpng/Package.fpc:${PORTSDIR}/graphics/fpc-libpng
+USE_FPC= fcl-base hash netdb pasjpeg paszlib pthreads libasync libpng
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-net/Makefile b/devel/fpc-fcl-net/Makefile
index 5d110654cc71..588f9f3bb389 100644
--- a/devel/fpc-fcl-net/Makefile
+++ b/devel/fpc-fcl-net/Makefile
@@ -5,24 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-net
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml \
- ${UNITSDIR}/fcl-passrc/Package.fpc:${PORTSDIR}/devel/fpc-fcl-passrc \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads
+USE_FPC= fcl-base fcl-xml fcl-passrc hash libasync netdb paszlib pthreads
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-passrc/Makefile b/devel/fpc-fcl-passrc/Makefile
index 69d14a09a993..db48ca88163b 100644
--- a/devel/fpc-fcl-passrc/Makefile
+++ b/devel/fpc-fcl-passrc/Makefile
@@ -5,16 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-passrc
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+USE_FPC= yes
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-registry/Makefile b/devel/fpc-fcl-registry/Makefile
index da0b91697d25..9afad6d8685b 100644
--- a/devel/fpc-fcl-registry/Makefile
+++ b/devel/fpc-fcl-registry/Makefile
@@ -5,23 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-registry
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads
+USE_FPC= fcl-base fcl-xml hash libasync netdb paszlib pthreads
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-web/Makefile b/devel/fpc-fcl-web/Makefile
index db42760e812b..2e585b6ce08d 100644
--- a/devel/fpc-fcl-web/Makefile
+++ b/devel/fpc-fcl-web/Makefile
@@ -5,30 +5,16 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-web
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml \
- ${UNITSDIR}/fcl-db/Package.fpc:${PORTSDIR}/devel/fpc-fcl-db \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
- ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
- ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
+USE_FPC= fcl-base fcl-xml fcl-db hash ibase libasync mysql netdb odbc oracle \
+ paszlib postgres pthreads sqlite
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fcl-xml/Makefile b/devel/fpc-fcl-xml/Makefile
index 6cb14c86f21f..7bc5a0963583 100644
--- a/devel/fpc-fcl-xml/Makefile
+++ b/devel/fpc-fcl-xml/Makefile
@@ -5,22 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-xml
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/hash/Package.fpc:${PORTSDIR}/security/fpc-hash \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
- ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
- ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
- ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads
+USE_FPC= fcl-base hash libasync netdb paszlib pthreads
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-fpmkunit/Makefile b/devel/fpc-fpmkunit/Makefile
index 1887f5f71d87..a76ff1b0aa75 100644
--- a/devel/fpc-fpmkunit/Makefile
+++ b/devel/fpc-fpmkunit/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fpmkunit
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal build system unit
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fv/Makefile b/devel/fpc-fv/Makefile
index 10a351dac40e..9284799e8b33 100644
--- a/devel/fpc-fv/Makefile
+++ b/devel/fpc-fv/Makefile
@@ -5,15 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fv
MAINTAINER= acm@FreeBSD.org
COMMENT= FreeVision is a Free Pascal unit for Delphi support
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- fpcmake:${PORTSDIR}/lang/fpc-utils
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-gconf/Makefile b/devel/fpc-gconf/Makefile
index f50aafdf028d..803a0a2949aa 100644
--- a/devel/fpc-gconf/Makefile
+++ b/devel/fpc-gconf/Makefile
@@ -5,20 +5,15 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -gconf
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal interface to GConf
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- fpcmake:${PORTSDIR}/lang/fpc-utils \
- ${UNITSDIR}/gtk/Package.fpc:${PORTSDIR}/x11-toolkits/fpc-gtk \
- ${UNITSDIR}/x11/Package.fpc:${PORTSDIR}/x11/fpc-x11 \
- ${UNITSDIR}/opengl/Package.fpc:${PORTSDIR}/graphics/fpc-opengl
+USE_FPC= gtk x11 opengl
-UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/extra/gnome1/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR+= ${WRKUNITDIR}
diff --git a/devel/fpc-gdbint/Makefile b/devel/fpc-gdbint/Makefile
index 60c9aeac651f..1ed0f18af876 100644
--- a/devel/fpc-gdbint/Makefile
+++ b/devel/fpc-gdbint/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMESUFFIX= -gdbint
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal unit providing interface to gdb
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/base/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-pthreads/Makefile b/devel/fpc-pthreads/Makefile
index bbc4dc4f1da5..aa3670f82b6a 100644
--- a/devel/fpc-pthreads/Makefile
+++ b/devel/fpc-pthreads/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -pthreads
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal wraper for the pthreads library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/base/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-regexpr/Makefile b/devel/fpc-regexpr/Makefile
index 790d67d0e155..495c2fc82634 100644
--- a/devel/fpc-regexpr/Makefile
+++ b/devel/fpc-regexpr/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -regexpr
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal regular expression routines
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/base/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-zlib/Makefile b/devel/fpc-zlib/Makefile
index d6ab2b8cfd3b..b015378b3ebc 100644
--- a/devel/fpc-zlib/Makefile
+++ b/devel/fpc-zlib/Makefile
@@ -5,15 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -zlib
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal interface to the zlib compression library
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- fpcmake:${PORTSDIR}/lang/fpc-utils
+USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/extra/${PKGNAMESUFFIX:S/-//}