aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/arcanist/Makefile6
-rw-r--r--devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php6
2 files changed, 7 insertions, 5 deletions
diff --git a/devel/arcanist/Makefile b/devel/arcanist/Makefile
index 12439a036ad1..943867425ded 100644
--- a/devel/arcanist/Makefile
+++ b/devel/arcanist/Makefile
@@ -12,11 +12,13 @@ COMMENT= Command line interface for Phabricator
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= php-libphutil>0:devel/libphutil
+
CONFLICTS= arc-*
PHP_DESTDIR= lib/php/arcanist
-RUN_DEPENDS= php-libphutil>0:devel/libphutil
-USES= php
+USES= php python:2.7,env shebangfix
+SHEBANG_FILES= scripts/breakout.py
USE_PHP= curl dom hash json simplexml
USE_GITHUB= yes
NO_BUILD= yes
diff --git a/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php b/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php
index 20a5214006b4..ba5ebc1c5d26 100644
--- a/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php
+++ b/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php
@@ -1,6 +1,6 @@
---- src/workflow/ArcanistVersionWorkflow.php.orig 2015-07-14 00:07:20.409019999 +0200
-+++ src/workflow/ArcanistVersionWorkflow.php 2015-07-14 00:27:09.586063998 +0200
-@@ -27,6 +27,13 @@
+--- src/workflow/ArcanistVersionWorkflow.php.orig 2017-06-09 15:12:37 UTC
++++ src/workflow/ArcanistVersionWorkflow.php
+@@ -27,6 +27,13 @@ EOTEXT
public function run() {
$console = PhutilConsole::getConsole();