aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/anjuta/Makefile43
-rw-r--r--devel/devhelp/Makefile37
-rw-r--r--devel/gconf2/Makefile21
-rw-r--r--devel/glade2/Makefile29
-rw-r--r--devel/gnome-vfs/Makefile30
-rw-r--r--devel/libglade2/Makefile14
-rw-r--r--devel/ptlib26/Makefile35
7 files changed, 97 insertions, 112 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index c7e0d4fa9160..5bcc8b205e90 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: anjuta
-# Date created: 31 March 2001
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/devel/anjuta/Makefile,v 1.67 2010/11/13 08:07:29 kwm Exp $
-#
+# $MCom: ports/devel/anjuta/Makefile,v 1.72 2012/12/13 20:33:05 kwm Exp $
PORTNAME= anjuta
PORTVERSION= 2.32.1.1
@@ -19,10 +15,10 @@ COMMENT= Integrated Development Environment for C and C++
BUILD_DEPENDS= autogen:${PORTSDIR}/devel/autogen \
bash:${PORTSDIR}/shells/bash \
p5-Locale-gettext>=1.05:${PORTSDIR}/devel/p5-Locale-gettext
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
- gladeui-1.10:${PORTSDIR}/devel/glade3 \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- gdl-1.3:${PORTSDIR}/x11-toolkits/gdl
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
+ gladeui-1:${PORTSDIR}/devel/glade3 \
+ unique-1.0:${PORTSDIR}/x11-toolkits/unique \
+ gdl-1:${PORTSDIR}/x11-toolkits/gdl
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
autogen:${PORTSDIR}/devel/autogen \
${LOCALBASE}/share/autotools:${PORTSDIR}/devel/autotools \
@@ -32,6 +28,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
gdb66:${PORTSDIR}/devel/gdb66 \
yelp:${PORTSDIR}/x11/yelp
+CONFLICTS= anjuta-3.[0-9]*
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
@@ -62,16 +60,17 @@ GCONF_SCHEMAS= anjuta-build-basic-autotools-plugin.schemas \
MAN1= anjuta.1 anjuta-launcher.1
-OPTIONS= SVN "Build subversion plugin" off \
- DEVHELP "Build devhelp plugin" on \
- GRAPHVIZ "Build inheritance plugin" on
+OPTIONS_DEFINE= SVN DEVHELP GRAPHVIZ
+OPTIONS_DEFAULT=DEVHELP GRAPHVIZ
+DEVHELP_DESC= Devhelp support
+GRAPHVIZ_DESC= inheritance plugin
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SVN)
+.if ${PORT_OPTIONS:MSVN}
BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-LIB_DEPENDS+= apr-1.4:${PORTSDIR}/devel/apr1
-LIB_DEPENDS+= neon.27:${PORTSDIR}/www/neon29
+LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
+LIB_DEPENDS+= neon:${PORTSDIR}/www/neon29
RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
PLIST_SUB+= SVN=""
.else
@@ -79,8 +78,8 @@ CONFIGURE_ARGS+=--disable-plugin-subversion
PLIST_SUB+= SVN="@comment "
.endif
-.if defined(WITH_DEVHELP)
-LIB_DEPENDS+= devhelp-2.1:${PORTSDIR}/devel/devhelp
+.if ${PORT_OPTIONS:MDEVHELP}
+LIB_DEPENDS+= devhelp-2:${PORTSDIR}/devel/devhelp
PLIST_SUB+= DEVHELP=""
.else
CONFIGURE_ARGS+=--disable-plugin-devhelp
@@ -90,7 +89,7 @@ CONFIGURE_ARGS+=--disable-plugin-devhelp
PLIST_SUB+= DEVHELP=""
.endif
-.if defined(WITH_GRAPHVIZ)
+.if ${PORT_OPTIONS:MGRAPHVIZ}
CONFIGURE_ARGS+=--enable-graphviz
BUILD_DEPENDS+= neato:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS+= neato:${PORTSDIR}/graphics/graphviz
@@ -111,7 +110,7 @@ post-configure:
${WRKSRC}/plugins/symbol-db/symbol-db-prefs.h
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in AUTHORS COPYING ChangeLog FUTURE INSTALL NEWS README \
doc/ScintillaDoc.html TODO
@@ -120,4 +119,4 @@ post-install:
.endif
@-update-mime-database ${PREFIX}/share/mime
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index eb7ea57a2739..220d19ed4556 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: devhelp
-# Date created: 29 May 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/devel/devhelp/Makefile,v 1.38 2010/09/28 09:09:20 kwm Exp $
+# $MCom: ports/devel/devhelp/Makefile,v 1.45 2012/09/01 23:02:09 mezz Exp $
PORTNAME= devhelp
PORTVERSION= 2.32.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= devel gnome
MASTER_SITES= GNOME
@@ -16,40 +13,44 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Developer help browser for GNOME 2
-LIB_DEPENDS= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2 \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2 \
+ unique-1.0:${PORTSDIR}/x11-toolkits/unique
+
+CONFLICTS= devhelp-3.[0-9]*
USE_BZIP2= yes
USE_XORG= x11
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui libwnck
+USES= pathfix
+USE_GNOME= intlhack gnomeprefix libgnomeui libwnck
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
GCONF_SCHEMAS= devhelp.schemas
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-OPTIONS= GEDIT "Enable GEdit plug-in support" off
+OPTIONS_DEFINE= GEDIT
+GEDIT_DESC= Enable GEdit plug-in support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GEDIT)
-BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
-RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+.if ${PORT_OPTIONS:MGEDIT}
+BUILD_DEPENDS+= gedit<3.0.0:${PORTSDIR}/editors/gedit
+RUN_DEPENDS+= gedit<3.0.0:${PORTSDIR}/editors/gedit
PLIST_SUB+= GEDIT=""
.else
PLIST_SUB+= GEDIT="@comment "
.endif
post-patch:
-.if defined(WITHOUT_GEDIT)
+.if ! ${PORT_OPTIONS:MGEDIT}
@${REINPLACE_CMD} -e 's|gedit-plugin||' \
${WRKSRC}/misc/Makefile.in
@${REINPLACE_CMD} -e 's|-DGTK_DISABLE_SINGLE_INCLUDES||g' \
${WRKSRC}/src/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index f89b14f1afc2..417886e1a3aa 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gconf2
-# Date created: 28th June 2000
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/devel/gconf2/Makefile,v 1.124 2010/11/15 22:14:03 kwm Exp $
-#
PORTNAME= gconf2
PORTVERSION= 2.32.0
@@ -25,12 +21,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- polkit-gobject-1.0:${PORTSDIR}/sysutils/polkit
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ polkit-gobject-1:${PORTSDIR}/sysutils/polkit
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_GNOME= gnomehier gnomehack orbit2 gtk20 libxml2 ltverhack \
+USES= pathfix
+USE_GNOME= gnomehier orbit2 gtk20 libxml2 ltverhack \
referencehack intlhack dconf
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
@@ -43,11 +40,11 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gconftool-2.1 gsettings-data-convert.1 \
gsettings-schema-convert.1
-OPTIONS= LDAP "Enable LDAP support" off
+OPTIONS_DEFINE= LDAP
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-openldap
PLIST_SUB+= LDAP=""
@@ -59,6 +56,6 @@ PLIST_SUB+= LDAP="@comment "
post-install:
-${LOCALBASE}/bin/gio-querymodules ${PREFIX}/lib/gio/modules
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index fe9179e9be11..19a901af3f82 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: glade2
-# Date created: 02 June 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/devel/glade2/Makefile,v 1.20 2007/08/04 03:51:29 marcus Exp $
-#
PORTNAME= glade
PORTVERSION= 2.12.2
@@ -23,28 +19,25 @@ USE_BZIP2= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack gtk20 desktopfileutils
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack gtk20 desktopfileutils
USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= GNOME "Enable gnome support" on #\
-# GNOMEDB "Enable libgnomedb support" off
+OPTIONS_DEFINE= GNOME
+OPTIONS_DEFAULT=GNOME
+GNOME_DESC= Gnome support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GNOME)
-CONFIGURE_ARGS+= --disable-gnome
-.else
+.if ${PORT_OPTIONS:MGNOME}
USE_GNOME+= libgailgnome libgnomeui
CONFIGURE_ARGS+= --enable-gnome
+.else
+CONFIGURE_ARGS+= --disable-gnome
.endif
-#.if defined(WITH_GNOMEDB)
-#USE_GNOME+= libgnomedb
-#CONFIGURE_ARGS+= --enable-gnome-db
-#.else
CONFIGURE_ARGS+= --disable-gnome-db
-#.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 71a93666a3b1..68eb29059d1c 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnomevfs2
-# Date created: 28th June 2000
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/devel/gnome-vfs/Makefile,v 1.191 2010/09/29 12:30:29 kwm Exp $
-#
PORTNAME= gnome-vfs
PORTVERSION= 2.24.4
@@ -24,7 +20,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomemimedata gconf2 \
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack gnomemimedata gconf2 \
ltverhack referencehack
USE_AUTOTOOLS= libtool
USE_OPENSSL= yes
@@ -44,11 +41,12 @@ GCONF_SCHEMAS= desktop_default_applications.schemas \
desktop_gnome_url_handlers.schemas system_dns_sd.schemas \
system_http_proxy.schemas system_smb.schemas
-OPTIONS= SAMBA "Enable SMB volume support" on \
- MDNS "Enable Bonjour/Rendezvous support" on \
- HAL "Enable HAL support" on
+OPTIONS_DEFINE= SAMBA MDNS HAL
+OPTIONS_DEFAULT=SAMBA MDNS HAL
+SAMBA_DESC= Enable SMB volume support
+MDNS_DESC= Enable Bonjour/Rendezvous support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libfam.so) || !defined(WITHOUT_FAM)
USE_FAM= yes
@@ -58,22 +56,22 @@ USE_FAM= yes
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
.endif
-.if !defined(WITHOUT_HAL)
+.if ${PORT_OPTIONS:MHAL}
CONFIGURE_ARGS+=--enable-hal
-LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+LIB_DEPENDS+= hal:${PORTSDIR}/sysutils/hal
.else
CONFIGURE_ARGS+=--disable-hal
.endif
-.if !defined(WITHOUT_SAMBA)
-LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+.if ${PORT_OPTIONS:MSAMBA}
+LIB_DEPENDS+= smbclient:${PORTSDIR}/net/samba-libsmbclient
PLIST_SUB+= SAMBA=""
.else
PLIST_SUB+= SAMBA="@comment "
CONFIGURE_ARGS+=--disable-samba
.endif
-.if !defined(WITHOUT_MDNS)
+.if ${PORT_OPTIONS:MMDNS}
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
.else
CONFIGURE_ARGS+=--disable-avahi
@@ -103,6 +101,6 @@ pre-configure:
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index c35ccb33e9ba..9c4ac1599bd2 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libglade2
-# Date created: 18 August 1999
-# Whom: Ade Lovett <ade@lovett.com>
-#
+# Created by: Ade Lovett <ade@lovett.com>
# $FreeBSD$
# $MCom: ports/devel/libglade2/Makefile,v 1.26 2007/08/01 16:13:48 mezz Exp $
-#
PORTNAME= libglade2
PORTVERSION= 2.6.4
@@ -26,7 +22,8 @@ RUN_DEPENDS= xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack libxml2 gtk20 referencehack
+USES= pathfix
+USE_GNOME= libxml2 gtk20 referencehack
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc \
@@ -37,11 +34,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= XMLCATALOG="${LOCALBASE}/bin/xmlcatalog" \
CATALOG_PORTS_XML="${LOCALBASE}/share/xml/catalog.ports"
-OPTIONS= PYTHON "Use Python" on
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT=PYTHON
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
diff --git a/devel/ptlib26/Makefile b/devel/ptlib26/Makefile
index 08db889050bf..95fa4b33dd4b 100644
--- a/devel/ptlib26/Makefile
+++ b/devel/ptlib26/Makefile
@@ -13,7 +13,7 @@ COMMENT= A cross platform C++ library, used by OPAL
LICENSE=MPL
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
CONFLICTS= pwlib-1.* ptlib-2.4.* ptlib-2.8.*
@@ -29,43 +29,40 @@ CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-oss --enable-plugins --with-expat-dir="${LOCALBASE}"
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
-OPTIONS= ODBC "Use ODBC" Off \
- ALSA "Use ALSA (experimental)" Off \
- V4L "Use Video4Linux" Off \
- BSDVIDEO "Enable BSD video support" On \
- SDL "Use SDL" On \
- LDAP "Enable LDAP support" Off
+OPTIONS_DEFINE= ODBC ALSA V4L BSDVIDEO SDL LDAP
+OPTIONS_DEFAULT=BSDVIDEO SDL
+BSDVIDEO_DESC= BSD video support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
PLIST_SUB+= PORTVERSION=${PORTVERSION} \
PVERSION_MAJOR=${PORTVERSION:C/.[0-9]+$//g} \
PVERSION_MINOR=${PORTVERSION:C/^[0-9]+.[0-9]+.//}
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
ALL_TARGET= optshared debugshared
BROKEN= debug libs install broken
.else
ALL_TARGET= optshared
.endif
-.if defined(WITH_ODBC)
+.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+= --enable-odbc
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
.else
CONFIGURE_ARGS+= --disable-odbc
.endif
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MALSA}
CONFIGURE_ARGS+= --enable-alsa
PLIST_SUB+= ALSA=""
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
.else
CONFIGURE_ARGS+= --disable-alsa
PLIST_SUB+= ALSA="@comment "
.endif
-.if defined(WITH_BSDVIDEO)
+.if ${PORT_OPTIONS:MBSDVIDEO}
CONFIGURE_ARGS+=--enable-bsdvideo
PLIST_SUB+= BSDVIDEO=""
WITH_VIDEO=1
@@ -74,7 +71,7 @@ CONFIGURE_ARGS+=--disable-bsdvideo
PLIST_SUB+= BSDVIDEO="@comment "
.endif
-.if defined(WITH_V4L)
+.if ${PORT_OPTIONS:MV4L}
CONFIGURE_ARGS+=--enable-v4l --enable-v4l2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -87,7 +84,7 @@ CONFIGURE_ARGS+=--disable-v4l
PLIST_SUB+= V4L="@comment "
.endif
-.if defined(WITH_VIDEO)
+.if ${PORT_OPTIONS:MVIDEO}
CONFIGURE_ARGS+= --enable-video
PLIST_SUB+= VIDEODIR=""
.else
@@ -95,13 +92,13 @@ CONFIGURE_ARGS+= --disable-video
PLIST_SUB+= VIDEODIR="@comment "
.endif
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
USE_SDL+= sdl
.else
CONFIGURE_ARGS+= --disable-sdl
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-openldap --with-ldap-dir="${LOCALBASE}"
.else
@@ -136,6 +133,8 @@ CONFIGURE_ARGS+= --disable-dc
#PLIST_SUB+= DC1394="@comment "
#.endif
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpt|-lpt-${PORTVERSION:C/.[0-9]+$//g}|' ${WRKSRC}/ptlib.pc.in
@${REINPLACE_CMD} -e 's|-lasound|-lasound -L${LOCALBASE}/lib|' ${WRKSRC}/plugins/sound_alsa/Makefile