aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-bit64/Makefile18
-rw-r--r--devel/R-cran-bit64/distinfo2
-rw-r--r--devel/R-cran-bit64/pkg-descr9
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a2bf6d897c42..96ac87783b86 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -13,6 +13,7 @@
SUBDIR += R-cran-RUnit
SUBDIR += R-cran-Rcpp
SUBDIR += R-cran-bit
+ SUBDIR += R-cran-bit64
SUBDIR += R-cran-bitops
SUBDIR += R-cran-caTools
SUBDIR += R-cran-caret
diff --git a/devel/R-cran-bit64/Makefile b/devel/R-cran-bit64/Makefile
new file mode 100644
index 000000000000..0586ac91ba2c
--- /dev/null
+++ b/devel/R-cran-bit64/Makefile
@@ -0,0 +1,18 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bit64
+DISTVERSION= 0.9-5
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= S3 Class for Vectors of 64bit Integers
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= R-cran-bit>=1.1.12:${PORTSDIR}/devel/R-cran-bit
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-bit64/distinfo b/devel/R-cran-bit64/distinfo
new file mode 100644
index 000000000000..141b25bfb9be
--- /dev/null
+++ b/devel/R-cran-bit64/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bit64_0.9-5.tar.gz) = 8f529f9e92caa133ced9c63f327a2682b70fac3f4fa96a0e95fcf50ddda8e53b
+SIZE (bit64_0.9-5.tar.gz) = 121087
diff --git a/devel/R-cran-bit64/pkg-descr b/devel/R-cran-bit64/pkg-descr
new file mode 100644
index 000000000000..f4a6dff2c3e7
--- /dev/null
+++ b/devel/R-cran-bit64/pkg-descr
@@ -0,0 +1,9 @@
+Package 'bit64' provides serializable S3 atomic 64bit (signed)
+integers that can be used in vectors, matrices, arrays and data.frames.
+Methods are available for coercion from and to logicals, integers,
+doubles, characters and factors as well as many elementwise and
+summary functions. Many fast algorithmic operations such as 'match'
+and 'order' support interactive data exploration and manipulation
+and optionally leverage caching.
+
+WWW: https://cran.r-project.org/web/packages/bit64/