aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/py-crcmod/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/py-crcmod/Makefile b/devel/py-crcmod/Makefile
index 3a75fc96dbe7..a9b39e2c4afb 100644
--- a/devel/py-crcmod/Makefile
+++ b/devel/py-crcmod/Makefile
@@ -3,19 +3,20 @@
PORTNAME= crcmod
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/ \
- CHEESESHOP
+MASTER_SITES= CHEESESHOP \
+ SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rm@FreeBSD.org
COMMENT= Module for Cyclic Redundancy Check (CRC) calculations
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= *
@@ -24,5 +25,6 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/changelog ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/crcmod/_crcfunext.so
.include <bsd.port.mk>