aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/p4genpatch/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/devel/p4genpatch/Makefile b/devel/p4genpatch/Makefile
index ab4e8ee081d6..b47d348ceb21 100644
--- a/devel/p4genpatch/Makefile
+++ b/devel/p4genpatch/Makefile
@@ -1,35 +1,34 @@
# Created by: bms@FreeBSD.org
# $FreeBSD$
-PORTNAME= p4genpatch
-PORTVERSION= 1
-CATEGORIES= devel
-MASTER_SITES= #
+PORTNAME= p4genpatch
+PORTVERSION= 1
+CATEGORIES= devel
+MASTER_SITES= #
DISTFILES=
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Helper scripts for generating RCS patches from Perforce
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Helper scripts for generating RCS patches from Perforce
-RUN_DEPENDS= p4:${PORTSDIR}/devel/p4
+RUN_DEPENDS= p4:${PORTSDIR}/devel/p4
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
-USES= shebangfix perl5
+USES= shebangfix perl5
-SCRIPTS= bin/p4genpatch bin/p4d2p
-PLIST_FILES= ${SCRIPTS}
+SCRIPTS= bin/p4genpatch bin/p4d2p
+PLIST_FILES= ${SCRIPTS}
-SHEBANG_FILES= ${SCRIPTS}
+SHEBANG_FILES= ${SCRIPTS}
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} -r ${FILESDIR}/bin ${WRKSRC}
do-install:
.for script in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${STAGEDIR}${PREFIX}/bin
.endfor
.include <bsd.port.mk>