aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/scons/Makefile15
-rw-r--r--devel/scons/pkg-plist3
2 files changed, 5 insertions, 13 deletions
diff --git a/devel/scons/Makefile b/devel/scons/Makefile
index 251be67142bd..3aad5869f03f 100644
--- a/devel/scons/Makefile
+++ b/devel/scons/Makefile
@@ -7,14 +7,10 @@ CATEGORIES= devel python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= gavin@16degrees.com.au
-COMMENT= A build tool alternative to make
+COMMENT= Build tool alternative to make
RUN_DEPENDS+= python2:${PORTSDIR}/lang/python2
-.if !defined (NO_INSTALL_MANPAGES)
-MAN1= scons.1 sconsign.1 scons-time.1
-.endif
-
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_EGGINFODIR= ${PREFIX}/lib/scons-${PORTVERSION}
@@ -23,11 +19,4 @@ PLIST_SUB+= SCONS_VER=${PORTVERSION}
USE_PYTHON= -2.7
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if defined (NO_INSTALL_MANPAGES)
-PYDISTUTILS_INSTALLARGS+= --no-install-man
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/scons/pkg-plist b/devel/scons/pkg-plist
index f70ddfb95a24..63137a54469b 100644
--- a/devel/scons/pkg-plist
+++ b/devel/scons/pkg-plist
@@ -580,6 +580,9 @@ lib/scons-%%SCONS_VER%%/SCons/dblite.pyo
lib/scons-%%SCONS_VER%%/SCons/exitfuncs.py
lib/scons-%%SCONS_VER%%/SCons/exitfuncs.pyc
lib/scons-%%SCONS_VER%%/SCons/exitfuncs.pyo
+man/man1/scons-time.1.gz
+man/man1/scons.1.gz
+man/man1/sconsign.1.gz
@dirrm lib/scons-%%SCONS_VER%%/SCons/compat
@dirrm lib/scons-%%SCONS_VER%%/SCons/Variables
@dirrm lib/scons-%%SCONS_VER%%/SCons/Tool/packaging