aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/swig13/Makefile6
-rw-r--r--devel/swig20/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index e3cf048220bd..41a13cc6916c 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -30,8 +30,10 @@ PLIST_SUB+= VER="${VER}"
.include <bsd.port.pre.mk>
post-patch:
- ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/; \
+ s|$$RUBY |${RUBY} |; \
+ s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
+ ' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
${WRKSRC}/Lib/lua/luarun.swg
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index e3cf048220bd..41a13cc6916c 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -30,8 +30,10 @@ PLIST_SUB+= VER="${VER}"
.include <bsd.port.pre.mk>
post-patch:
- ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/; \
+ s|$$RUBY |${RUBY} |; \
+ s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
+ ' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
${WRKSRC}/Lib/lua/luarun.swg