aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/sfio/Makefile11
-rw-r--r--devel/sfio/pkg-plist8
2 files changed, 11 insertions, 8 deletions
diff --git a/devel/sfio/Makefile b/devel/sfio/Makefile
index 644e3542e2f2..d18422af1372 100644
--- a/devel/sfio/Makefile
+++ b/devel/sfio/Makefile
@@ -21,6 +21,7 @@ EXTRACT_AFTER_ARGS= # empty
NO_WRKSUBDIR= yes
MAN1= iffe.1
MAN3= sfio.3
+PLIST= ${WRKDIR}/pkg-plist
# Remove a test that's too clever for its own good
post-extract:
@@ -30,6 +31,16 @@ post-extract:
do-build:
@cd ${WRKDIR}/src/lib/sfio && ${MAKE} all -f makefile
+pre-install:
+ ${RM} -f ${PLIST}
+.for ii in ast_common sfio sfio_t stdio
+ ${ECHO_CMD} include/sfio/${ii}.h >> ${PLIST}
+.endfor
+.for ii in sfio stdio
+ ${ECHO_CMD} lib/lib${ii}.a >> ${PLIST}
+.endfor
+ ${ECHO_CMD} @dirrm include/sfio >> ${PLIST}
+
do-install:
${MKDIR} ${PREFIX}/include/sfio
${INSTALL_DATA} ${WRKDIR}/include/* ${PREFIX}/include/sfio
diff --git a/devel/sfio/pkg-plist b/devel/sfio/pkg-plist
deleted file mode 100644
index 4b1099715997..000000000000
--- a/devel/sfio/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-@comment $FreeBSD$
-include/sfio/ast_common.h
-include/sfio/sfio.h
-include/sfio/sfio_t.h
-include/sfio/stdio.h
-lib/libsfio.a
-lib/libstdio.a
-@dirrm include/sfio