aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/subversion/Makefile.common10
-rw-r--r--devel/subversion/files/patch-Makefile.in9
-rw-r--r--devel/subversion17/Makefile2
-rw-r--r--devel/subversion17/Makefile.common10
-rw-r--r--devel/subversion17/files/patch-Makefile.in15
5 files changed, 17 insertions, 29 deletions
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index ae392249a3ca..2a573e1f0b51 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -3,7 +3,7 @@
PORTNAME= subversion
PORTVERSION= 1.8.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
DIST_SUBDIR= subversion18
@@ -45,7 +45,7 @@ GNOME_KEYRING_LIB_DEPENDS= libgcr.so:${PORTSDIR}/security/gnome-keyring
KDE_KWALLET_CONFIGURE_OFF= --without-kwallet
KDE_KWALLET_CONFIGURE_ON= --with-kwallet=${KDE4_PREFIX}
-KDE_KWALLET_USE= KDE4=kdelibs runtime
+KDE_KWALLET_USE= KDE4=kdelibs,runtime
MAINTAINER_DEBUG_CFLAGS= -g
MAINTAINER_DEBUG_CONFIGURE_ON= --enable-maintainer-mode --enable-debug
@@ -113,3 +113,9 @@ post-patch:
.if ${PORT_OPTIONS:MFREEBSD_TEMPLATE} && defined(ORGANIZATION)
@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
.endif
+# shebangfix
+ ${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
+ | ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+ -e '1s|#\!/bin/env|#\!/usr/bin/env|' \
+ -e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
+
diff --git a/devel/subversion/files/patch-Makefile.in b/devel/subversion/files/patch-Makefile.in
index 16c7ba88b208..ac484ac2d08e 100644
--- a/devel/subversion/files/patch-Makefile.in
+++ b/devel/subversion/files/patch-Makefile.in
@@ -12,12 +12,3 @@ This patch is required to build SVN Apache modules with staging support
javahl_javadir = @libdir@/svn-javahl
javahl_javahdir = @libdir@/svn-javahl/include
-@@ -207,7 +207,7 @@
- LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
-
- # special link rule for mod_dav_svn
--LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
-+LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -inst-prefix-dir ${DESTDIR}
-
- # Special LDFLAGS for some libraries
- libsvn_auth_gnome_keyring_LDFLAGS = @libsvn_auth_gnome_keyring_LDFLAGS@
diff --git a/devel/subversion17/Makefile b/devel/subversion17/Makefile
index ee63306055c9..125daaf74aa1 100644
--- a/devel/subversion17/Makefile
+++ b/devel/subversion17/Makefile
@@ -199,7 +199,7 @@ post-install: ${MKREPOS_TARGET}
@${MAKE} -C ${WRKSRC} install-tools ${MAKE_ARGS}
.endif
@${MKDIR} ${STAGEDIR}${DATADIR}
- @(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
+ @(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' --exclude '*.bak' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/devel/subversion17/Makefile.common b/devel/subversion17/Makefile.common
index 0a1442238267..aa557b758034 100644
--- a/devel/subversion17/Makefile.common
+++ b/devel/subversion17/Makefile.common
@@ -3,7 +3,7 @@
PORTNAME= subversion
PORTVERSION= 1.7.14
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
DIST_SUBDIR= subversion17
@@ -47,7 +47,7 @@ GNOME_KEYRING_LIB_DEPENDS= libgcr.so:${PORTSDIR}/security/gnome-keyring
KDE_KWALLET_CONFIGURE_OFF= --without-kwallet
KDE_KWALLET_CONFIGURE_ON= --with-kwallet=${KDE4_PREFIX}
-KDE_KWALLET_USE= KDE4=kdelibs runtime
+KDE_KWALLET_USE= KDE4=kdelibs,runtime
MAINTAINER_DEBUG_CFLAGS= -g
MAINTAINER_DEBUG_CONFIGURE_ON= --enable-maintainer-mode --enable-debug
@@ -123,3 +123,9 @@ post-patch:
.if ${PORT_OPTIONS:MFREEBSD_TEMPLATE} && defined(ORGANIZATION)
@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
.endif
+# shebangfix
+ ${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
+ | ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+ -e '1s|#\!/bin/env|#\!/usr/bin/env|' \
+ -e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
+
diff --git a/devel/subversion17/files/patch-Makefile.in b/devel/subversion17/files/patch-Makefile.in
deleted file mode 100644
index 97cea24f1752..000000000000
--- a/devel/subversion17/files/patch-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
-========================================================================
-This patch is required to build SVN Apache modules with staging support
-========================================================================
---- ./Makefile.in.orig 2013-10-21 19:51:16.000000000 +0200
-+++ ./Makefile.in 2013-10-21 19:51:31.000000000 +0200
-@@ -209,7 +209,8 @@
- LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
-
- # special link rule for mod_dav_svn
--LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
-+LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -inst-prefix-dir ${DESTDIR}
-+
-
- # Special LDFLAGS for some libraries
- libsvn_auth_gnome_keyring_LDFLAGS = @libsvn_auth_gnome_keyring_LDFLAGS@