aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Test-File-Contents/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/p5-Test-File-Contents/Makefile b/devel/p5-Test-File-Contents/Makefile
index c000ad17678f..7359f308489a 100644
--- a/devel/p5-Test-File-Contents/Makefile
+++ b/devel/p5-Test-File-Contents/Makefile
@@ -15,7 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@rbt.ca
COMMENT= Test routines for examining the contents of files
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_MODBUILD= yes
@@ -24,7 +26,9 @@ MAN3= Test::File::Contents.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if m{use warnings};' ${WRKSRC}/Build.PL \
+ ${WRKSRC}/lib/Test/File/Contents.pm
.endif
.include <bsd.port.post.mk>