aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/e4graph/Makefile8
-rw-r--r--devel/e4graph/distinfo2
-rw-r--r--devel/e4graph/files/patch-configure25
3 files changed, 5 insertions, 30 deletions
diff --git a/devel/e4graph/Makefile b/devel/e4graph/Makefile
index 1b760c4cee82..79a36cfc9296 100644
--- a/devel/e4graph/Makefile
+++ b/devel/e4graph/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= e4graph
-PORTVERSION= 1.0a6
-PORTREVISION= 2
+PORTVERSION= 1.0a7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library that persistently stores graph like data
@@ -25,9 +25,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/all
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-metakit=${LOCALBASE} \
- --with-tcl=${LOCALBASE} --enable-tcl \
+ --with-tcl=${LOCALBASE}/lib/tcl8.3 --enable-tcl \
--with-expat=${LOCALBASE} --enable-xml
-CFLAGS+= -fpermissive
+CFLAGS+= -fpermissive -I${LOCALBASE}/include/tcl8.3
MAKEFILE= makefile
INSTALLS_SHLIB= yes
diff --git a/devel/e4graph/distinfo b/devel/e4graph/distinfo
index e57a185b3f40..f097467b9f6e 100644
--- a/devel/e4graph/distinfo
+++ b/devel/e4graph/distinfo
@@ -1 +1 @@
-MD5 (e4graph-1.0a6.tar.gz) = 694eb8efc4259d07770c121f7a1c6347
+MD5 (e4graph-1.0a7.src.tar.gz) = dba634f99c326b153751868af7cbe475
diff --git a/devel/e4graph/files/patch-configure b/devel/e4graph/files/patch-configure
deleted file mode 100644
index 06ba97bd5b1c..000000000000
--- a/devel/e4graph/files/patch-configure
+++ /dev/null
@@ -1,25 +0,0 @@
---- configure.orig Wed May 8 00:04:10 2002
-+++ configure Tue Jul 16 03:14:40 2002
-@@ -731,9 +731,9 @@
- # pointing at a Tcl installation in a non-standard place.
-
- if test x"${with_tcl}" != x ; then
-- if test -f "${with_tcl}/include/tcl.h" ; then
-+ if test -f "${with_tcl}/include/tcl8.3/tcl.h" ; then
- ac_cv_c_tcl=`(cd ${with_tcl}; pwd)`
-- ac_cv_c_tcl_inc=${ac_cv_c_tcl}/include
-+ ac_cv_c_tcl_inc=${ac_cv_c_tcl}/include/tcl8.3
- ac_cv_c_tcl_lib=${ac_cv_c_tcl}/lib
- else
- { echo "configure: error: ${with_tcl}/include doesn't contain tcl.h" 1>&2; exit 1; }
-@@ -804,8 +804,8 @@
- if test x"${with_expat}" != x ; then
- if test -f "${with_expat}/include/expat.h" ; then
- ac_cv_c_expat=`(cd ${with_expat}/include; pwd)`
-- ac_cv_c_expat_inc=${ac_cv_c_expat}/include
-- ac_cv_c_expat_lib=${ac_cv_c_expat}/lib
-+ ac_cv_c_expat_inc=${with_expat}/include
-+ ac_cv_c_expat_lib=${with_expat}/lib
- else
- { echo "configure: error: ${with_expat}/include does not contain expat.h" 1>&2; exit 1; }
- fi