aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-ruby-statsd/Makefile25
-rw-r--r--devel/rubygem-ruby-statsd/distinfo2
-rw-r--r--devel/rubygem-ruby-statsd/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b18a4793b8c0..6b5d6fc31781 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3746,6 +3746,7 @@
SUBDIR += rubygem-ruby-ole
SUBDIR += rubygem-ruby-prof
SUBDIR += rubygem-ruby-sdl-ffi
+ SUBDIR += rubygem-ruby-statsd
SUBDIR += rubygem-ruby2ruby
SUBDIR += rubygem-ruby_parser
SUBDIR += rubygem-rubyforge
diff --git a/devel/rubygem-ruby-statsd/Makefile b/devel/rubygem-ruby-statsd/Makefile
new file mode 100644
index 000000000000..f2c55b03d4d2
--- /dev/null
+++ b/devel/rubygem-ruby-statsd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: rubygem-statsd
+# Date created: Feburary 18 2012
+# Whom: Evan Sarmiento <bsdports@wayfair.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= statsd
+PORTVERSION= 0.5.4
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby port of the statsd python and node.js tools
+
+RUN_DEPENDS= rubygem-eventmachine>=0.12.10:${PORTSDIR}/devel/rubygem-eventmachine \
+ rubygem-mongo>=1.2.4:${PORTSDIR}/databases/rubygem-mongo \
+ rubygem-erubis>=2.6.6:${PORTSDIR}/www/rubygem-erubis
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/statsd
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-statsd/distinfo b/devel/rubygem-ruby-statsd/distinfo
new file mode 100644
index 000000000000..c4548e3a074d
--- /dev/null
+++ b/devel/rubygem-ruby-statsd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/statsd-0.5.4.gem) = d183c6e41905541fa09f58bb833ac52366ded565c1e542d0fe7998948854bd11
+SIZE (rubygem/statsd-0.5.4.gem) = 10752
diff --git a/devel/rubygem-ruby-statsd/pkg-descr b/devel/rubygem-ruby-statsd/pkg-descr
new file mode 100644
index 000000000000..c7036239aee6
--- /dev/null
+++ b/devel/rubygem-ruby-statsd/pkg-descr
@@ -0,0 +1,6 @@
+Statsd implementation in Ruby
+
+A network daemon for aggregating statistics (counters and timers),
+rolling them up, then sending them to graphite or mongodb.
+
+WWW: https://github.com/quasor/statsd